<!DOCTYPE html> <html lang="en-US" xmlns:og="http://opengraphprotocol.org/schema/" xmlns:fb="http://www.facebook.com/2008/fbml"> <head><link rel="dns-prefetch" href="//fonts.googleapis.com">
<link rel="preload" href="https://www.page1publications.com/wp-content/cache/borlabs_cache/1/css/b085e8af1ab71bfbeaddbef65423df320bff3412_https.css" as="style">
<link rel="stylesheet" href="https://www.page1publications.com/wp-content/cache/borlabs_cache/1/css/b085e8af1ab71bfbeaddbef65423df320bff3412_https.css" type="text/css" media="all"><link href="https://fonts.googleapis.com/css?family=Oswald%3A400" rel="stylesheet"> <meta charset="UTF-8" /> <meta name="viewport" content="width=device-width, initial-scale=1.0" /> <meta http-equiv="X-UA-Compatible" content="IE=edge" /> <link rel="profile" href="http://gmpg.org/xfn/11" /> <link rel="pingback" href="https://www.page1publications.com/xmlrpc.php" />   <!--[if lt IE 9]> <script src="https://www.page1publications.com/wp-content/themes/bb-theme/js/html5shiv.js"></script> <script src="https://www.page1publications.com/wp-content/themes/bb-theme/js/respond.min.js"></script> <![endif]--> <title>Glenn A. Iverson, 84 &#8211; Page 1 Publications</title> <script>
      var bwg_admin_ajax = 'https://www.page1publications.com/wp-admin/admin-ajax.php?action=shortcode_bwg';
      var bwg_ajax_url = 'https://www.page1publications.com/wp-admin/admin-ajax.php?action';
      var bwg_plugin_url = 'https://www.page1publications.com/wp-content/plugins/photo-gallery';
      document.addEventListener('DOMContentLoaded', function(){ // Analog of $(document).ready(function(){
        bwg_check_ready = function () {}
        document.onkeyup = function(e){
          if ( e.key == 'Escape' ) {
            bwg_remove_loading_block();
          }
        };
      });

      // Set shortcode popup dimensions.
      function bwg_set_shortcode_popup_dimensions() {
        var H = jQuery(window).height(), W = jQuery(window).width();
        jQuery("#TB_title").hide().first().show();
        // New
        var tbWindow = jQuery('#TB_window');
        if (tbWindow.size()) {
          tbWindow.width(W).height(H);
          jQuery('#TB_iframeContent').width(W).height(H);
          tbWindow.attr('style',
            'top:'+ '0px !important;' +
            'left:' + '0px !important;' +
            'margin-left:' + '0;' +
            'z-index:' + '1000500;' +
            'max-width:' + 'none;' +
            'max-height:' + 'none;' +
            '-moz-transform:' + 'none;' +
            '-webkit-transform:' + 'none'
          );
        }
        // Edit
        var tbWindow = jQuery('.mce-window[aria-label="Photo Gallery"]');
        if (tbWindow.length) {
          // To prevent wp centering window with old sizes.
          setTimeout(function() {
            tbWindow.width(W).height(H);
            tbWindow.css({'top': 0, 'left': 0, 'margin-left': '0', 'z-index': '1000500'});
            tbWindow.find('.mce-window-body').width(W).height(H);
          }, 10);
        }
      }
      // Create loading block.
      function bwg_create_loading_block() {
        jQuery('body').append('<div class="loading_div" style="display:block; width: 100%; height: 100%; opacity: 0.6; position: fixed; background-color: #000000; background-image: url('+ bwg_plugin_url +'/images/spinner.gif); background-position: center; background-repeat: no-repeat; background-size: 50px; z-index: 1001000; top: 0; left: 0;"></div>');
      }
      // Remove loading block.
      function bwg_remove_loading_block() {
        jQuery(".loading_div", window.parent.document).remove();
        jQuery('.loading_div').remove();
      }
	  </script> <script type="text/javascript" >            function apbct_attach_event_handler__backend(elem, event, callback){                if(typeof window.addEventListener === "function") elem.addEventListener(event, callback);                else                                              elem.attachEvent(event, callback);            }            apbct_attach_event_handler__backend(window, 'load', function(){                ctSetCookie('ct_checkjs', '1693971071' );            });</script><link rel='dns-prefetch' href='//ajax.googleapis.com' /> <link rel='dns-prefetch' href='//www.google.com' /> <link rel='dns-prefetch' href='//fonts.googleapis.com' /> <link href='https://fonts.gstatic.com' crossorigin rel='preconnect' /> <link rel="alternate" type="application/rss+xml" title="Page 1 Publications &raquo; Feed" href="https://www.page1publications.com/feed/" /> <link rel="alternate" type="application/rss+xml" title="Page 1 Publications &raquo; Comments Feed" href="https://www.page1publications.com/comments/feed/" /> <link rel="alternate" type="application/rss+xml" title="Page 1 Publications &raquo; Glenn A. Iverson, 84 Comments Feed" href="https://www.page1publications.com/2021/11/01/glenn-a-iverson-84/feed/" /> <meta property="og:title" content="Glenn A. Iverson, 84"/><meta property="og:type" content="article"/><meta property="og:url" content="https://www.page1publications.com/2021/11/01/glenn-a-iverson-84/"/><meta property="og:site_name" content="Page 1 Publications"/><meta property="og:image" content="https://www.page1publications.com/wp-content/uploads/2021/11/Glenn.jpg"/>                       <style id='wp-polls-inline-css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://www.page1publications.com/wp-content/plugins/webads-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>              <script src='https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js?ver=1.12.4' id='jquery-js'></script> <script src='https://www.page1publications.com/wp-content/plugins/event-calendar-wd/js/gmap/gmap3.js?ver=5.1.32_5956d74b908fe' id='ecwd-gmap-public-js'></script> <script src='https://www.page1publications.com/wp-content/plugins/event-calendar-wd/js/ecwd_popup.js?ver=5.1.32_5956d74b908fe' id='ecwd-popup-js'></script> <script src='https://www.page1publications.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4' id='jquery-ui-core-js'></script> <script src='https://www.page1publications.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4' id='jquery-ui-widget-js'></script> <script src='https://www.page1publications.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4' id='jquery-ui-mouse-js'></script> <script src='https://www.page1publications.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4' id='jquery-ui-draggable-js'></script> <script src='https://www.page1publications.com/wp-includes/js/imagesloaded.min.js?ver=5.5.6' id='imagesloaded-js'></script> <script src='https://www.page1publications.com/wp-includes/js/masonry.min.js?ver=4.2.2' id='masonry-js'></script> <script id='ecwd-public-js-extra'>
var ecwd = {"ajaxurl":"https:\/\/www.page1publications.com\/wp-admin\/admin-ajax.php","ajaxnonce":"654d65a3ff","loadingText":"Loading...","event_popup_title_text":"Event Details","plugin_url":"https:\/\/www.page1publications.com\/wp-content\/plugins\/event-calendar-wd","gmap_type":"ROADMAP","gmap_redirect":"","gmap_key":"AIzaSyCaa0RtTxnqA-JnjHxBpIGMd3YpYmbJm8g","gmap_style":""};
</script> <script src='https://www.page1publications.com/wp-content/plugins/event-calendar-wd/js/scripts.js?ver=5.1.32_5956d74b908fe' id='ecwd-public-js'></script> <script src='https://www.page1publications.com/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1' id='addtoany-js'></script> <script id='ct_public-js-extra'>
var ctPublic = {"_ajax_nonce":"3cee6be6d9","_rest_nonce":"f479076574","_ajax_url":"\/wp-admin\/admin-ajax.php","_rest_url":"https:\/\/www.page1publications.com\/wp-json\/","_apbct_ajax_url":"https:\/\/www.page1publications.com\/wp-content\/plugins\/cleantalk-spam-protect\/lib\/Cleantalk\/ApbctWP\/Ajax.php","data__set_cookies":"1","data__set_cookies__alt_sessions_type":"0","pixel__setting":"0","pixel__enabled":"","pixel__url":null,"data__email_check_before_post":"1"};
</script> <script src='https://www.page1publications.com/wp-content/plugins/cleantalk-spam-protect/js/apbct-public.min.js?apbct_ver=5.159.5&#038;ver=5.159.5' id='ct_public-js'></script> <script src='https://www.page1publications.com/wp-content/plugins/cleantalk-spam-protect/js/cleantalk-modal.min.js?ver=5.159.5' id='cleantalk-modal-js'></script> <script id='ct_nocache-js-extra'>
var ctNocache = {"ajaxurl":"\/wp-admin\/admin-ajax.php","info_flag":"","set_cookies_flag":"1","blog_home":"https:\/\/www.page1publications.com\/"};
</script> <script src='https://www.page1publications.com/wp-content/plugins/cleantalk-spam-protect/js/cleantalk_nocache.min.js?ver=5.159.5' id='ct_nocache-js'></script> <script src='https://www.page1publications.com/wp-content/plugins/photo-gallery/js/jquery.sumoselect.min.js?ver=3.0.3' id='sumoselect-js'></script> <script src='https://www.page1publications.com/wp-content/plugins/photo-gallery/js/jquery.mobile.min.js?ver=1.4.5' id='jquery-mobile-js'></script> <script src='https://www.page1publications.com/wp-content/plugins/photo-gallery/js/jquery.mCustomScrollbar.concat.min.js?ver=2.5.75' id='mCustomScrollbar-js'></script> <script src='https://www.page1publications.com/wp-content/plugins/photo-gallery/js/jquery.fullscreen-0.4.1.min.js?ver=0.4.1' id='jquery-fullscreen-js'></script> <script id='bwg_frontend-js-extra'>
var bwg_objectsL10n = {"bwg_field_required":"field is required.","bwg_mail_validation":"This is not a valid email address.","bwg_search_result":"There are no images matching your search.","bwg_select_tag":"Select Tag","bwg_order_by":"Order By","bwg_search":"Search","bwg_show_ecommerce":"Show Ecommerce","bwg_hide_ecommerce":"Hide Ecommerce","bwg_show_comments":"Show Comments","bwg_hide_comments":"Hide Comments","bwg_restore":"Restore","bwg_maximize":"Maximize","bwg_fullscreen":"Fullscreen","bwg_exit_fullscreen":"Exit Fullscreen","bwg_search_tag":"SEARCH...","bwg_tag_no_match":"No tags found","bwg_all_tags_selected":"All tags selected","bwg_tags_selected":"tags selected","play":"Play","pause":"Pause","is_pro":"1","bwg_play":"Play","bwg_pause":"Pause","bwg_hide_info":"Hide info","bwg_show_info":"Show info","bwg_hide_rating":"Hide rating","bwg_show_rating":"Show rating","ok":"Ok","cancel":"Cancel","select_all":"Select all","lazy_load":"0","lazy_loader":"https:\/\/www.page1publications.com\/wp-content\/plugins\/photo-gallery\/images\/ajax_loader.png","front_ajax":"0","bwg_tag_see_all":"see all tags","bwg_tag_see_less":"see less tags"};
</script> <script src='https://www.page1publications.com/wp-content/plugins/photo-gallery/js/scripts.min.js?ver=2.5.75' id='bwg_frontend-js'></script> <script src='https://www.page1publications.com/wp-content/plugins/webads-admin/public/js/webads-admin-public.js?ver=1.2.9' id='webads-admin-js'></script> <script src='https://www.page1publications.com/wp-content/plugins/webads-adrotate-legacy-widget/public/js/webads-adrotate-legacy-widget-public.js?ver=1.0.0' id='webads-adrotate-legacy-widget-js'></script> <script src='https://www.page1publications.com/wp-content/plugins/webads-church-directory/public/js/webads-church-directory-public.js?ver=1.0' id='webads-church-directory-js'></script> <script src='https://www.page1publications.com/wp-content/plugins/webads-crosswords/public/js/webads-crosswords-public.js?ver=1.0.0' id='webads-crosswords-js'></script> <script src='https://www.page1publications.com/wp-content/plugins/webads-display-ads/public/js/jquery.sudoSlider.js?ver=1.0.0' id='webads-display-ads-js'></script> <script src='https://www.page1publications.com/wp-content/plugins/webads-elasticpress/public/js/webads-elasticpress-public.js?ver=1.0.0' id='webads-elasticpress-js'></script> <script src='https://www.page1publications.com/wp-content/plugins/webads-event-calendar-wd/public/js/webads-event-calendar-wd-public.js?ver=1.0.0' id='webads-event-calendar-wd-js'></script> <script src='https://www.page1publications.com/wp-content/plugins/webads-google-analytics/public/js/webads-google-analytics-public.js?ver=1.0.0' id='webads-google-analytics-js'></script> <script src='https://www.page1publications.com/wp-content/plugins/webads-htm-classifieds/public/js/webads-htm-classifieds-public.js?ver=1.0.0' id='webads-htm-classifieds-js'></script> <script src='https://www.page1publications.com/wp-content/plugins/webads-news-ticker/public/js/webads-news-ticker-public.js?ver=23' id='webads-news-ticker-js'></script> <script src='https://www.page1publications.com/wp-content/plugins/webads-online-edition-v1/public/js/webads-online-edition-v1-public.js?ver=1.0.3' id='webads-online-edition-v1-js'></script> <script src='https://www.page1publications.com/wp-content/plugins/webads-paperboy-signup/public/js/webads-paperboy-signup-public.js?ver=1.0.0' id='webads-paperboy-signup-js'></script> <script src='https://www.page1publications.com/wp-content/plugins/webads-password-protect/public/js/webads-password-protect-public.js?ver=1.0.0' id='webads-password-protect-js'></script> <script src='https://www.page1publications.com/wp-content/plugins/webads-password-protect/public/js/js.cookie.min.js?ver=5.5.6' id='jquery-cookie-js'></script> <script src='https://www.page1publications.com/wp-content/plugins/webads-photo-gallery/public/js/webads-photo-gallery-public.js?ver=2.5.40.03' id='webads-photo-gallery-js'></script> <script src='https://www.page1publications.com/wp-content/plugins/webads-rss/public/js/webads-rss-public.js?ver=1.0.0' id='webads-rss-js'></script> <script src='https://www.page1publications.com/wp-content/plugins/webads-social/public/js/webads-social-public.js?ver=0.0.1' id='webads-social-js'></script> <script src='https://www.page1publications.com/wp-content/plugins/webads-syndicated-stories/public/js/webads-syndicated-stories-public.js?ver=1.0.1' id='webads-syndicated-stories-js'></script> <script src='https://www.page1publications.com/wp-content/plugins/webads-weather-v2/public/js/webads-weather-public.js?ver=2.0.8' id='webads-weather-js'></script> <link rel="https://api.w.org/" href="https://www.page1publications.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.page1publications.com/wp-json/wp/v2/posts/267055" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.page1publications.com/xmlrpc.php?rsd" /> <link rel='prev' title='ROSEAU COUNTY (Minn.) BOARD OF COMMISSIONERS MEETING/October 12, 2021' href='https://www.page1publications.com/2021/10/29/roseau-county-minn-board-of-commissioners-meeting-october-12-2021/' /> <link rel="canonical" href="https://www.page1publications.com/2021/11/01/glenn-a-iverson-84/" /> <link rel='shortlink' href='https://www.page1publications.com/?p=267055' /> <link rel="alternate" type="application/json+oembed" href="https://www.page1publications.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.page1publications.com%2F2021%2F11%2F01%2Fglenn-a-iverson-84%2F" /> <link rel="alternate" type="text/xml+oembed" href="https://www.page1publications.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.page1publications.com%2F2021%2F11%2F01%2Fglenn-a-iverson-84%2F&#038;format=xml" /> <script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script> <style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { margin:0px 0px 0px 0px;width:100%; max-width:300px; height:100%; max-height:250px; }
	.g-3 { margin:0px 0px 0px 0px;width:100%; max-width:100px; height:100%; max-height:100px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style> <script type="text/javascript">document.documentElement.className += " js";</script> <link rel="shortcut icon" href="https://www.page1publications.com/wp-content/uploads/2021/03/favicon-16x16-1.png"/> <script>
    (function (i, s, o, g, r, a, m) {
      i['GoogleAnalyticsObject'] = r;
      i[r] = i[r] || function () {
          (i[r].q = i[r].q || []).push(arguments)
      }, i[r].l = 1 * new Date();
      a = s.createElement(o),
          m = s.getElementsByTagName(o)[0];
      a.async = 1;
      a.src = g;
      m.parentNode.insertBefore(a, m)
  })
  (window, document, 'script', '//www.google-analytics.com/analytics.js', 'ga');
  ga('create', 'UA-36148557-31', 'auto', {
      'siteSpeedSampleRate': '1'   });
    ga('send', 'pageview');
  </script></head> <body class="post-template-default single single-post postid-267055 single-format-standard ecwd-theme-parent-bb-theme ecwd-theme-child-bb-theme-child fl-framework-bootstrap fl-preset-color01 fl-fixed-width fl-has-sidebar" itemscope="itemscope" itemtype="http://schema.org/WebPage"> <script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script> <script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/21843165966/Page_1_Publications_DY', [728, 90], 'div-gpt-ad-1611788603323-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script><a aria-label="Skip to content" class="fl-screen-reader-text" href="#fl-main-content">Skip to content</a><div> <div class="fl-page-bar"> <div class="fl-page-bar-container container"> <div class="fl-page-bar-row row"> <div class="col-md-8 hidden-sm text-left clearfix"> <div class="breakingNews" id="bn7"> <div class="bn-title"><h2>Breaking News</h2><span></span></div> <ul> <li><a href="https://www.page1publications.com/2021/10/28/powwow/">Masquerade Pow Wow held at CMS</a></li> <li><a href="https://www.page1publications.com/2021/10/27/consistency-hard-work-push-horien-to-career-milestone/">Consistency, hard work push Horien to career milestone</a></li> <li><a href="https://www.page1publications.com/2021/10/22/exclusive-charges-filed-allegedly-threatened-suicide-just-before-crash-killed-2-boys-in-egf/">EXCLUSIVE: Charges Filed, Allegedly Threatened Suicide Just Before Crash Killed 2 Boys In EGF</a></li> <li><a href="https://www.page1publications.com/2021/10/21/some-area-drivers-exam-stations-remain-closed-dvs-looks-to-deal-with-issue/">Some area driver’s exam stations remain closed: DVS looks to deal with issue</a></li> <li><a href="https://www.page1publications.com/2021/10/15/homecoming-2021/">Homecoming 2021</a></li> <li><a href="https://www.page1publications.com/2021/10/14/ymca-floating-pumpkin-patch-is-october-23/">YMCA FLOATING PUMPKIN PATCH IS OCTOBER 23</a></li> <li><a href="https://www.page1publications.com/2021/10/14/whispers-of-the-past-coming-together/">“Whispers of the Past” coming together</a></li> <li><a href="https://www.page1publications.com/2021/10/14/ready-for-the-challenge-hayley-moore-takes-over-as-new-badger-city-clerk/">Ready for the challenge: Hayley Moore takes over as new Badger City Clerk</a></li> <li><a href="https://www.page1publications.com/2021/10/12/city-of-karlstad-minn-approves-1-3-million-grant-agreement-for-new-airport/">City of Karlstad, Minn. approves $1.3 million grant agreement for new airport</a></li> <li><a href="https://www.page1publications.com/2021/10/07/water-light-led-bulb-giveaway-oct-7th-8th/">Water &#038; Light LED Bulb Giveaway Oct 7th &#038; 8th</a></li> </ul> <div class="bn-navi"> <span></span> <span></span> </div> </div> <script>
    (function( $ ) {
        $(window).load(function(e) {

            $("#bn7").breakingNews({
                effect		:"slide-v",
                autoplay	:true,
                timer		:7000,
                color		:'default'
            });

        });

    })( jQuery );
</script> <div class="fl-page-bar-text fl-page-bar-text-1"></div></div> <div class="col-md-4 col-sm-12 text-right clearfix"><ul id="menu-top-bar-menu" class="fl-page-bar-nav nav navbar-nav menu"><li id="menu-item-20756" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-20756 nav-item"><a href="#" class="nav-link">Contact Us</a> <ul class="sub-menu"> <li id="menu-item-284" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-284 nav-item"><a href="https://www.page1publications.com/contact-us/" class="nav-link">The Exponent</a></li> <li id="menu-item-20757" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20757 nav-item"><a href="https://www.page1publications.com/contact-us-north-star-news/" class="nav-link">North Star News</a></li> <li id="menu-item-20758" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20758 nav-item"><a href="https://www.page1publications.com/contact-us-the-tribune/" class="nav-link">The Tribune</a></li> <li id="menu-item-20759" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20759 nav-item"><a href="https://www.page1publications.com/contact-us-northern-light-region/" class="nav-link">The Northern Light</a></li> </ul> </li> <li id="menu-item-21799" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21799 nav-item"><a href="https://www.page1publications.com/about-us/" class="nav-link">About Us</a></li> <li id="menu-item-285" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-285 nav-item"><a class="nav-link">E-Editions</a> <ul class="sub-menu"> <li id="menu-item-22331" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22331 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=1b39bd64-3bf8-4219-b2d6-c49010cd5792" class="nav-link">North Star News</a></li> <li id="menu-item-22332" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22332 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=0edf69db-7621-496a-bc5d-30c51d25f9ef" class="nav-link">Northern Light Region</a></li> <li id="menu-item-22333" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22333 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=7e6a7f3b-d60a-4328-9883-3a86f55219b7" class="nav-link">The Exponent</a></li> <li id="menu-item-22334" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22334 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=bfda4ff1-9fd3-4b96-bfad-af5c10439939" class="nav-link">The Tribune</a></li> <li id="menu-item-264334" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-264334 nav-item"><a target="_blank" rel="noopener noreferrer" href="https://www.newstogo.us/editionviewer/default.aspx?Publication=0e4896ee-3a4d-423f-97fb-dc025cfed655" class="nav-link">Supplements</a></li> <li id="menu-item-265750" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-265750 nav-item"><a target="_blank" rel="noopener noreferrer" href="https://www.newstogo.us/editionviewer/default.aspx?Publication=47737b56-6ab7-4a1b-9649-d73a2ea73970" class="nav-link">Lake of the Woods Connection</a></li> </ul> </li> <li id="menu-item-286" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-286 nav-item"><a class="nav-link">Subscribe</a> <ul class="sub-menu"> <li id="menu-item-22335" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22335 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=1b39bd64-3bf8-4219-b2d6-c49010cd5792&#038;view=subscribe" class="nav-link">North Star News</a></li> <li id="menu-item-22336" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22336 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=0edf69db-7621-496a-bc5d-30c51d25f9ef&#038;view=subscribe" class="nav-link">Northern Light Region</a></li> <li id="menu-item-22337" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22337 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=7e6a7f3b-d60a-4328-9883-3a86f55219b7&#038;view=subscribe" class="nav-link">The Exponent</a></li> <li id="menu-item-22338" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22338 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=bfda4ff1-9fd3-4b96-bfad-af5c10439939&#038;view=subscribe" class="nav-link">The Tribune</a></li> </ul> </li> <li id="menu-item-287" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-287 nav-item"><a class="nav-link">Archives</a> <ul class="sub-menu"> <li id="menu-item-22339" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22339 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=1b39bd64-3bf8-4219-b2d6-c49010cd5792&#038;view=archives" class="nav-link">North Star News</a></li> <li id="menu-item-22340" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22340 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=0edf69db-7621-496a-bc5d-30c51d25f9ef&#038;view=archives" class="nav-link">Northern Light Region</a></li> <li id="menu-item-22341" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22341 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=7e6a7f3b-d60a-4328-9883-3a86f55219b7&#038;view=archives" class="nav-link">The Exponent</a></li> <li id="menu-item-22342" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22342 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=bfda4ff1-9fd3-4b96-bfad-af5c10439939&#038;view=archives" class="nav-link">The Tribune</a></li> <li id="menu-item-264335" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-264335 nav-item"><a target="_blank" rel="noopener noreferrer" href="https://www.newstogo.us/editionviewer/default.aspx?Publication=0e4896ee-3a4d-423f-97fb-dc025cfed655&#038;view=archives" class="nav-link">Supplements</a></li> </ul> </li> </ul> <div class="fl-social-icons"> <a href="https://www.facebook.com/Northern-Light-Region-123704497685047/" target="_blank" rel="noopener noreferrer"><span class="sr-only">Facebook</span><i aria-hidden="true" class="fab fa-facebook-f mono"></i></a><a href="mailto:rolly@wiktel.com" rel="noopener noreferrer"><span class="sr-only">Email</span><i aria-hidden="true" class="fas fa-envelope mono"></i></a></div> </div> </div> </div> </div> </div> <div class="fl-page"> <header class="fl-page-header fl-page-header-primary fl-page-nav-bottom fl-page-nav-toggle-button fl-page-nav-toggle-visible-mobile" itemscope="itemscope" itemtype="http://schema.org/WPHeader"> <div class="fl-page-header-wrap"> <div class="fl-page-header-container container"> <div class="fl-page-header-row row"> <div class="col-md-8 col-sm-8"> <div class="fl-page-header-logo" itemscope="itemscope" itemtype="http://schema.org/Organization"> <a href="https://www.page1publications.com" itemprop="url"><img loading="false" data-no-lazy="1" class="fl-logo-img" itemscope itemtype="https://schema.org/ImageObject" src="https://www.page1publications.com/wp-content/uploads/2021/01/header.png" data-retina="" title="" alt="Page 1 Publications" /><meta itemprop="name" content="Page 1 Publications" /></a> </div> </div> <div class="col-md-4 col-sm-4"> <div class="fl-page-header-content"> <div id="webads_weather_widget-2" class="widget widget_webads_weather_widget pull-right"> <script>
            jQuery(document).ready(function() {
                loadWeather('56721', 'transparent', 'East Grand Forks', '56721');
            });
        </script> <div id="webads-weather-56721" class="widget widget-webads-weather"> <a id="webads-weather-56721-link" href="https://www.page1publications.com"> <div class="awe-mini"> <div> <div class="col visual"> <span id="webads-weather-56721-temperature" class="temperature"></span> <i id="webads-weather-56721-image" class="weather-forecast-icon" style="background-size:contain"></i> </div> <div class="col info"> <span id="webads-weather-56721-location" class="location"></span> <span id="webads-weather-56721-conditions" class="forecast"></span> </div> </div> </div> </a> </div> <script>
            function loadWeather(zipcode, background, location, instanceid) {
                if (zipcode !== undefined) {
                    var location = String(location);
                    var instanceid = String(instanceid);
                    jQuery.ajax({
                        url: "https://ws.iadsnetwork.com/weather.svc/GetCurrentConditions",
                        data: { "zipcode": zipcode },
                        dataType: "json",
                        type: "GET",
                        contentType: "application/json; charset=utf-8",
                        success: function (data) {
                            if (data.d != null) {
                                var dtCC = data.d;
                                for (i = 0; i < dtCC.length; i++) {
                                    jQuery("#webads-weather-" + instanceid + "-temperature").append(dtCC[i].temperature);
                                    jQuery("#webads-weather-" + instanceid + "-location").append(location);
                                    jQuery("#webads-weather-" + instanceid + "-conditions").append(dtCC[i].conditions);
                                    jQuery("#webads-weather-" + instanceid + "-image").css('background-image', 'url(' + dtCC[i].image + ')');
                                    $link = jQuery("#webads-weather-" + instanceid + "-link").attr("href");
                                    jQuery("#webads-weather-" + instanceid + "-link").attr("href", $link + '/weather/?zipcode=' + dtCC[i].zipcode + '&location=' + encodeURIComponent(location));
                                    jQuery("#webads-weather-" + instanceid).css('background-color', background);
                                }
                            }
                        },
                        error: function (d) {
                            //alert("Error");
                        }
                    });
                }
            }
        </script> </div><div id="search-2" class="widget widget_search pull-right"><form aria-label="Search" method="get" role="search" action="https://www.page1publications.com/" title="Type and press Enter to search."> <input aria-label="Search" type="search" class="fl-search-input form-control" name="s" placeholder="Search" value="" onfocus="if (this.value === 'Search') { this.value = ''; }" onblur="if (this.value === '') this.value='Search';" /> </form> </div> </div> </div> </div> </div> </div> <div class="fl-page-nav-wrap"> <div class="fl-page-nav-container container"> <nav class="fl-page-nav navbar navbar-default" role="navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement"> <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".fl-page-nav-collapse"> <span>Menu</span> </button> <div class="fl-page-nav-collapse collapse navbar-collapse"> <ul id="menu-main-menu" class="nav navbar-nav menu"><li id="menu-item-1076" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-1076 nav-item"><a href="https://www.page1publications.com/" class="nav-link">Home</a></li> <li id="menu-item-296" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-296 nav-item"><a class="nav-link">E-Editions</a> <ul class="sub-menu"> <li id="menu-item-22323" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22323 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=1b39bd64-3bf8-4219-b2d6-c49010cd5792" class="nav-link">North Star News</a></li> <li id="menu-item-22324" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22324 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=0edf69db-7621-496a-bc5d-30c51d25f9ef" class="nav-link">Northern Light Region</a></li> <li id="menu-item-22325" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22325 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=7e6a7f3b-d60a-4328-9883-3a86f55219b7" class="nav-link">The Exponent</a></li> <li id="menu-item-22326" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22326 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=bfda4ff1-9fd3-4b96-bfad-af5c10439939" class="nav-link">The Tribune</a></li> <li id="menu-item-264333" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-264333 nav-item"><a target="_blank" rel="noopener noreferrer" href="https://www.newstogo.us/editionviewer/default.aspx?Publication=0e4896ee-3a4d-423f-97fb-dc025cfed655" class="nav-link">Supplements</a></li> <li id="menu-item-265749" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-265749 nav-item"><a target="_blank" rel="noopener noreferrer" href="https://www.newstogo.us/editionviewer/default.aspx?Publication=47737b56-6ab7-4a1b-9649-d73a2ea73970" class="nav-link">Lake of the Woods Connection</a></li> </ul> </li> <li id="menu-item-297" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-297 nav-item"><a class="nav-link">Subscribe</a> <ul class="sub-menu"> <li id="menu-item-22327" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22327 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=1b39bd64-3bf8-4219-b2d6-c49010cd5792&#038;view=subscribe" class="nav-link">North Star News</a></li> <li id="menu-item-22328" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22328 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=0edf69db-7621-496a-bc5d-30c51d25f9ef&#038;view=subscribe" class="nav-link">Northern Light Region</a></li> <li id="menu-item-22329" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22329 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=7e6a7f3b-d60a-4328-9883-3a86f55219b7&#038;view=subscribe" class="nav-link">The Exponent</a></li> <li id="menu-item-22330" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22330 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=bfda4ff1-9fd3-4b96-bfad-af5c10439939&#038;view=subscribe" class="nav-link">The Tribune</a></li> </ul> </li> <li id="menu-item-30182" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30182 nav-item"><a href="https://www.page1publications.com/category/public-notices/" class="nav-link">Public Notices</a></li> <li id="menu-item-292" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-292 nav-item"><a href="https://www.page1publications.com/obituaries/" class="nav-link">Obits</a></li> <li id="menu-item-4243" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-4243 nav-item"><a href="#" class="nav-link">Regional News</a> <ul class="sub-menu"> <li id="menu-item-4246" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4246 nav-item"><a href="https://www.page1publications.com/arkansas-news/" class="nav-link">Minnesota News</a></li> <li id="menu-item-4245" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4245 nav-item"><a href="https://www.page1publications.com/east-grand-fork-green-wave-news/" class="nav-link">East Grand Fork Green Wave News</a></li> <li id="menu-item-4244" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4244 nav-item"><a href="https://www.page1publications.com/fort-smith-news/" class="nav-link">St. Paul News</a></li> </ul> </li> <li id="menu-item-21777" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-21777 nav-item"><a href="#" class="nav-link">Connect</a> <ul class="sub-menu"> <li id="menu-item-21776" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21776 nav-item"><a href="https://www.page1publications.com/community-links/" class="nav-link">Community Links</a></li> <li id="menu-item-290" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-290 nav-item"><a href="https://www.page1publications.com/event-calendar/" class="nav-link">Events</a></li> <li id="menu-item-289" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-289 nav-item"><a href="https://www.page1publications.com/crossword/" class="nav-link">Crossword</a></li> </ul> </li> <li id="menu-item-20879" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-20879 nav-item"><a href="#" class="nav-link">Meet the Folks at:</a> <ul class="sub-menu"> <li id="menu-item-20875" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20875 nav-item"><a href="https://www.page1publications.com/meet-the-folks-at-the-exponent/" class="nav-link">The Exponent</a></li> <li id="menu-item-20876" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20876 nav-item"><a href="https://www.page1publications.com/20768-2/" class="nav-link">The Tribune</a></li> <li id="menu-item-20877" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20877 nav-item"><a href="https://www.page1publications.com/meet-the-folks-at-north-star-news/" class="nav-link">North Star News</a></li> <li id="menu-item-20878" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20878 nav-item"><a href="https://www.page1publications.com/20761-2/" class="nav-link">The Northern Light</a></li> </ul> </li> <li id="menu-item-21769" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-21769 nav-item"><a href="#" class="nav-link">Our Newspaper History</a> <ul class="sub-menu"> <li id="menu-item-21770" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21770 nav-item"><a href="https://www.page1publications.com/the-history-of-the-exponent/" class="nav-link">The Exponent</a></li> <li id="menu-item-21771" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21771 nav-item"><a href="https://www.page1publications.com/21764-2/" class="nav-link">The Tribune</a></li> <li id="menu-item-21772" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21772 nav-item"><a href="https://www.page1publications.com/the-history-of-north-star-news/" class="nav-link">North Star News</a></li> <li id="menu-item-21773" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21773 nav-item"><a href="https://www.page1publications.com/history-of-the-northern-light-region/" class="nav-link">The Northern Light Region</a></li> </ul> </li> <li id="menu-item-260872" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-260872 nav-item"><a href="https://www.page1publications.com/category/news/" class="nav-link">News</a></li> </ul> </div> </nav> </div> </div> </header> <div class="fl-page-content" itemprop="mainContentOfPage"> <div class="webads-userbar-wrapper" style="display: none;"><span class="webads-userbar"><span class="webads-userbar-name"></span><span class="fl-sep"> | </span><a href="https://www.page1publications.com/wp-admin/admin-post.php?action=webads_logout&webads_logout_nonce=DS9URN7DtQcxre6U"><span>logout</span></a></span></div> <script>
            $(document).ready(function(){
                if (Cookies.get('webads-auth-1811')) {
                    $(".webads-userbar-wrapper").show();
                    $(".webads-userbar-name").text(decodeURIComponent(Cookies.get('webads-username-1811')));
                } else {
                    $(".webads-userbar-wrapper").hide();
                }
            });
        </script> <div class="container"> <div class="row"> <div class="fl-content fl-content-left col-md-9"> <article class="fl-post post-267055 post type-post status-publish format-standard has-post-thumbnail hentry category-obituaries" id="fl-post-267055" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <header class="fl-post-header"> <h1 class="fl-post-title" itemprop="headline"> Glenn A. Iverson, 84 </h1> <div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author" itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person">By <a href="https://www.page1publications.com/author/editor/" itemprop="url"><span itemprop="name">Editor</span></a></span><span class="fl-sep"> | </span><span class="fl-post-date" itemprop="datePublished" datetime="2021-11-01">November 1, 2021</span><span class="fl-sep"> | </span><span class="fl-comments-popup-link"><a href="https://www.page1publications.com/2021/11/01/glenn-a-iverson-84/#respond" tabindex="-1" aria-hidden="true">0 <i class="fa fa-comment"></i></a></span></div><meta itemprop="image" content="https://www.page1publications.com/wp-content/uploads/2021/11/Glenn.jpg"><meta itemprop="interactionCount" content="UserComments:0"> </header> <div class="fl-post-content clearfix" itemprop="text"> <p><img loading="lazy" class="alignnone size-full wp-image-267056" src="https://www.page1publications.com/wp-content/uploads/2021/11/Glenn.jpg" alt="" width="268" height="345" srcset="https://www.page1publications.com/wp-content/uploads/2021/11/Glenn.jpg 268w, https://www.page1publications.com/wp-content/uploads/2021/11/Glenn-233x300.jpg 233w" sizes="(max-width: 268px) 100vw, 268px" /></p> <p>&nbsp;</p> <p>A Funeral Service for Glenn A. Iverson of Greenbush, MN will be held on Tuesday, November 2, 2021 at 11:00AM at United Free Lutheran Church in Greenbush, MN. Visitation will be held on Monday, November 1, 2021 from 5-7 PM at Helgeson Funeral Home in Roseau, MN with a prayer service at 7PM. Interment will be held at a later date.</p> <p>Glenn was born October 2nd, 1937, to Clarence and Jeanette (Carlson) Iverson, in Detroit Lakes, MN.  He was baptized and confirmed in the Lutheran faith at Olivet Lutheran Church, Fargo, ND.</p> <p>After graduation from Fargo High, he joined the U.S. Navy for four years.  After an honorable discharge, he worked for a short time in Minneapolis, MN and then for his father in Fargo.</p> <p>Glenn and Avis (Holm) were married September 2, 1961, at Oiland Lutheran Free Church, rural Greenbush.  The couple lived in Fargo for a short while before moving to Minneapolis, where he worked for Sexton Data Products as a treasurer and office manager.  In January of 1973 the family moved to Greenbush where he worked for Thompson Motors, Art Anderson Construction, and then was a self-employed carpenter.  He then worked for Marvin Windows and Doors in Warroad, where he worked in Round Tops and then for many years in the special calculations department in the Corporate Office.   Glenn retired in April 2001 and again started doing many handy man jobs, as well as being the grounds keeper for many years at Oak View Golf Course in Greenbush through 2020, which he looked forward to every spring and summer.  He was also very involved in his church, United Free Lutheran Church, serving as president, secretary and treasurer and was a member of the Town and Country, the Roseau American Legion and the Forty and Eight Club, Roseau. He enjoyed taking in local sporting events (especially boys’ and girls’ basketball) and loved going to his grandchildren’s events.   If you needed help, he was but a phone call away.  He liked to cook, bake apple pies and do cross word puzzles.</p> <p>Glenn loved his family dearly and loved to get down on the floor with his grandchildren and play games or listen to them explain their school activities to him.   He was a real “softie” where family was concerned, be it his wife, children, grandchildren and great grandchildren, nieces, and nephews and also his friends.  Glenn and Avis also enjoyed spending 10 winters in Arizona. They sold their home of 40 yrs, just outside of Greenbush, and moved to Roseau in 2014.  He and Avis loved to dance, and he will always be remembered for his sense of humor and great personality.</p> <p>Glenn is survived by his loving wife of 60 years, Avis, son Gregg (Pam) Iverson, Roseau, and their children Camille (Eric) Massaro of Baudette, Mn and Garrett (Rachel) Iverson of Fargo; Daughter Jennifer (John) Lee, Moorhead and their children Andrea and Jack Lee of Moorhead.; Great grandchildren, Eliza, Fletcher and Asher Massaro; Sister Carol (Verne) Wik, Dilworth, Mn and brother Roger Iverson, Fargo, brother-in-law Merton Kirkeide, Greenbush; and many nieces and nephews that he loved dearly.  He is also survived by lifelong childhood friend Marv Olson, his wife Annette and their children.</p> <p>He was preceded in death by his parents, father and mother-in-law, Arnt and Belle Holm; half-sister Joyce Klausen; half-brother George (wife Ruth) Litke; and an infant half-brother; Brothers Russel Iverson and Eugene Iverson; Sister’s-in-law, Lois Iverson, Judy Iverson, Annette “2P” Kirkeide, Carol Miller and Ruby Holm; Brother’s-in-law, Clifford Holm and Myron Miller.</p> <p>Blessed be his memory.   In lieu of flowers, memorials are preferred to United Free Lutheran Church in Greenbush.</p> <p>Glenn&#8217;s family requests that all in attendance wear masks to the services.</p> <div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.page1publications.com/2021/11/01/glenn-a-iverson-84/" data-a2a-title="Glenn A. Iverson, 84"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.page1publications.com%2F2021%2F11%2F01%2Fglenn-a-iverson-84%2F&amp;linkname=Glenn%20A.%20Iverson%2C%2084" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.page1publications.com%2F2021%2F11%2F01%2Fglenn-a-iverson-84%2F&amp;linkname=Glenn%20A.%20Iverson%2C%2084" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div> </div> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags">Posted in <a href="https://www.page1publications.com/category/obituaries/" rel="category tag">Obituaries</a></div></div> <div class="fl-comments"> <div id="respond"> <h3 class="fl-comments-respond-title">Leave a Comment</h3> <form class="fl-comment-form" action="https://www.page1publications.com/wp-comments-post.php" method="post"> <label for="author">Name (required)</label> <input type="text" name="author" class="form-control" value="" tabindex="1" aria-required='true' /> <br/> <label for="email">Email (will not be published) (required)</label> <input type="text" name="email" class="form-control" value="" tabindex="2" aria-required='true' /> <br/> <label for="comment">Comment</label> <textarea name="comment" class="form-control" cols="60" rows="8" tabindex="4"></textarea> <br/> <div class="g-recaptcha" data-sitekey="6LdvRcMZAAAAAEXIplzSR6ZvSkSZTV1inA8BbwkV"></div> <br> <input name="submit" type="submit" class="btn btn-primary" tabindex="5" value="Submit Comment"/> <input type='hidden' name='comment_post_ID' value='267055' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /> <input type="hidden" id="ct_checkjs_15d4e891d784977cacbfcbb00c48f133" name="ct_checkjs" value="0" /> <div class="fl-comment-form-cancel"> <a rel="nofollow" id="cancel-comment-reply-link" href="/2021/11/01/glenn-a-iverson-84/#respond" style="display:none;">Click here to cancel reply.</a> </div> </form> </div> </div> <style>
                    .fl-post-featured-post {
                        border-bottom: 1px solid #e6e6e6;
                        margin-bottom: 10px;
                        padding-bottom: 0px;
                        margin-left: 20px;
                    }

                    .fl-post-featured-image-beside .fl-post-featured-image {
                        float: left;
                        width: 120px;
                        padding-right: 5px;
                    }

                    .fl-clear {
                        clear: both;
                    }

                    h5.fl-post-featured-title {
                        margin: 0 0 10px;
                        padding: 0;
                        font-weight: bold;
                    }

                    .fl-post-featured-image {
                        margin-bottom: 10px;
                    }

                    .fl-post-featured-image img {
                        height: auto !important;
                        width: 100% !important;
                    }

                    .fl-post-featured-header {
                        margin-bottom: 15px;
                    }

                </style> <div id="webads-related-posts"> <h3>Related Posts</h3> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.page1publications.com/2021/10/28/lena-adams-96/" rel="bookmark" title="Lena Adams, 96"> <img width="300" height="300" src="https://www.page1publications.com/wp-content/uploads/2021/10/Adams-Lena-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.page1publications.com/2021/10/28/lena-adams-96/" rel="bookmark" title="Lena Adams, 96">Lena Adams, 96</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> October 28, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.page1publications.com/2021/10/28/lena-adams-96/#respond" tabindex="-1" aria-hidden="true">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.page1publications.com/2021/10/27/agnes-viola-siggerud-102/" rel="bookmark" title="Agnes Viola Siggerud, 102"> <img width="294" height="300" src="https://www.page1publications.com/wp-content/uploads/2021/10/Agnes-Siggerud-294x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.page1publications.com/2021/10/27/agnes-viola-siggerud-102/" rel="bookmark" title="Agnes Viola Siggerud, 102">Agnes Viola Siggerud, 102</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> October 27, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.page1publications.com/2021/10/27/agnes-viola-siggerud-102/#respond" tabindex="-1" aria-hidden="true">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.page1publications.com/2021/10/25/lorraine-hines-90/" rel="bookmark" title="Lorraine Hines, 90"> <img width="300" height="300" src="https://www.page1publications.com/wp-content/uploads/2021/10/Hines-Lorraine-folder-photo-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.page1publications.com/2021/10/25/lorraine-hines-90/" rel="bookmark" title="Lorraine Hines, 90">Lorraine Hines, 90</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> October 25, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.page1publications.com/2021/10/25/lorraine-hines-90/#respond" tabindex="-1" aria-hidden="true">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.page1publications.com/2021/10/25/robert-cameron-87/" rel="bookmark" title="Robert Cameron, 87"> <img width="177" height="270" src="https://www.page1publications.com/wp-content/uploads/2021/10/5.-Obit-Robert-Cameron.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.page1publications.com/2021/10/25/robert-cameron-87/" rel="bookmark" title="Robert Cameron, 87">Robert Cameron, 87</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> October 25, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.page1publications.com/2021/10/25/robert-cameron-87/#respond" tabindex="-1" aria-hidden="true">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.page1publications.com/2021/10/19/lawrence-sonny-hendrickson-67/" rel="bookmark" title="Lawrence “Sonny” Hendrickson, 67"> <img width="300" height="300" src="https://www.page1publications.com/wp-content/uploads/2021/10/5.-Lawrence-Hendrickson-photo-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.page1publications.com/2021/10/19/lawrence-sonny-hendrickson-67/" rel="bookmark" title="Lawrence “Sonny” Hendrickson, 67">Lawrence “Sonny” Hendrickson, 67</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> October 19, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.page1publications.com/2021/10/19/lawrence-sonny-hendrickson-67/#respond" tabindex="-1" aria-hidden="true">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> </div> </article> </div> <div class="fl-sidebar fl-sidebar-right fl-sidebar-display-always col-md-3" itemscope="itemscope" itemtype="https://schema.org/WPSideBar"> <aside id="adrotate_widgets-6" class="fl-widget widget_adrotate_widgets"><div class="a-single a-22"><a onClick="ga('send', 'event', 'Adverts', 'click', 'INewz', 1.00, {'nonInteraction': 1});" href="https://www.page1publications.com/inewz/"><img onload="ga('send', 'event', 'Adverts', 'impression', 'INewz', 2.00, {'nonInteraction': 1});" src="https://www.page1publications.com/wp-content/uploads/2019/10/inewzwebad.jpg" /></a></div></aside><aside id="5e3b600a0ebce-2" class="fl-widget 5e3b600a0ebce"><!-- Error, Ad (24) is not available at this time due to schedule/budgeting/geolocation/mobile restrictions! --></aside><aside id="webads_displayads_widget-2" class="fl-widget widget_webads_displayads_widget"><h4 class="fl-widget-title">Our Advertisers</h4> <style>
                    #displayAds img {
                        width: 100%;
                        height: auto;
                    }

                                        #displayAdsWrapper {
                        height: 1500px;
                        overflow: hidden;
                    }
                    

                </style> <div id="displayAdsWrapper"> <div id="displayAds"> <ul id="displayAdsUL"> </ul> </div> </div> <script>
                    (function( $ ) {
                        $(document).ready(function () {
                            $("#displayAdsWrapper").hide();
                            loadDisplayAds(1811, 100, 1);
                        });

                        function loadDisplayAds(memberid, count, thumbtype) {

                            if (memberid !== undefined) {
                                var memberid = String(memberid);
                                var count = String(count);
                                var thumbtype = String(thumbtype);
                                if (memberid.length == 4) {
                                    $.ajax({
                                        url: "https://ws.iadsnetwork.com/displayads.svc/GetDisplayAds",
                                        data: { "memberid": memberid, "count": count, "thumbtype": thumbtype },
                                        dataType: "json",
                                        type: "GET",
                                        contentType: "application/json; charset=utf-8",
                                        success: function (data) {

                                            if (data.d != null) {
                                                $("#displayAdsUL").empty();
                                                var dtDisplayAd = data.d;

                                                for (i = 0; i < dtDisplayAd.length; i++) {
                                                    if (typeof ga !== "undefined") {
                                                        // safe to use the function
                                                        ga('send','event','Adverts','impression',dtDisplayAd[i].name,2,{'nonInteraction':1});
                                                        $("#displayAdsUL").append('<li style="padding-bottom: 5px;"><a onClick="ga(\'send\',\'event\',\'Adverts\',\'click\',\'' + dtDisplayAd[i].name + '\',1,{\'nonInteraction\':1});" href="' + dtDisplayAd[i].url + '" target="_blank"><img src="' + dtDisplayAd[i].img + '" alt=" " /></a></li>');
                                                    } else {
                                                        $("#displayAdsUL").append('<li style="padding-bottom: 5px;"><a href="' + dtDisplayAd[i].url + '" target="_blank"><img src="' + dtDisplayAd[i].img + '" alt=" " /></a></li>');
                                                    }
                                                }
                                                setTimeout(function(){ startSlider(i) }, 1000);
                                            }
                                        },
                                        error: function (d) {
                                            //alert("Error");
                                        }
                                    });
                                } else {
                                    $("#displayAdsWrapper").empty();
                                }
                            }
                        }

                        function startSlider(count) {
                            var isAuto = true;
                            var pauseLen = '5000';

                            $("#displayAds").sudoSlider({
                                vertical: true,
                                continuous: true,
                                                                slideCount: count+1,
                                auto: isAuto,
                                                                autoHeight: false,
                                                                pause:  pauseLen,
                                prevNext: false,
                                useCSS: false,
                                autoWidth: true
                            });
                            $("#displayAdsWrapper").show();
                        }
                    })( jQuery );

                </script> </aside><aside id="adrotate_widgets-5" class="fl-widget widget_adrotate_widgets"><!-- Error, Ad (14) is not available at this time due to schedule/budgeting/geolocation/mobile restrictions! --></aside><aside id="adrotate_widgets-2" class="fl-widget widget_adrotate_widgets"><div class="g g-1"><div class="g-dyn a-3 c-1"><a onClick="ga('send', 'event', 'Adverts', 'click', 'Employment', 1.00, {'nonInteraction': 1});" href="http://www.hometownemploymentnetwork.com/default.aspx?affiliateid=1119" target="_blank"><img onload="ga('send', 'event', 'Adverts', 'impression', 'Employment', 2.00, {'nonInteraction': 1});" src="http://www.page1publications.com/wp-content/uploads/2016/08/Jobs.png" /></a></div></div></aside><aside id="adrotate_widgets-3" class="fl-widget widget_adrotate_widgets"><div class="a-single a-10"><a onClick="ga('send', 'event', 'Adverts', 'click', 'Breaking News Signup', 1.00, {'nonInteraction': 1});" href="http://www.page1publications.com/breaking-news-signup/"><img onload="ga('send', 'event', 'Adverts', 'impression', 'Breaking News Signup', 2.00, {'nonInteraction': 1});" src="http://www.page1publications.com/wp-content/uploads/2016/04/breakingNewsHeader.png" /></a></div></aside><aside id="webads_facebook_widget-2" class="fl-widget widget_webads_facebook_widget"><h4 class="fl-widget-title">Like Us On Facebook</h4> <div id="fb-root"></div> <script async defer crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v5.0"></script> <div class="fb-page" data-href="https://www.facebook.com/Northern-Light-Region-123704497685047/" data-tabs="" data-width="" data-height="" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><blockquote cite="https://www.facebook.com/facebook" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/facebook">Facebook</a></blockquote></div> </aside><aside id="webads_facebook_widget-4" class="fl-widget widget_webads_facebook_widget"> <div id="fb-root"></div> <script async defer crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v5.0"></script> <div class="fb-page" data-href="https://www.facebook.com/North-Star-News-344310152276116/" data-tabs="" data-width="" data-height="" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><blockquote cite="https://www.facebook.com/facebook" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/facebook">Facebook</a></blockquote></div> </aside><aside id="webads_facebook_widget-3" class="fl-widget widget_webads_facebook_widget"> <div id="fb-root"></div> <script async defer crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v5.0"></script> <div class="fb-page" data-href="https://www.facebook.com/The-Exponent-East-Grand-Forks-MN-106126462791312/" data-tabs="" data-width="" data-height="" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><blockquote cite="https://www.facebook.com/facebook" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/facebook">Facebook</a></blockquote></div> </aside><aside id="webads_facebook_widget-5" class="fl-widget widget_webads_facebook_widget"> <div id="fb-root"></div> <script async defer crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v5.0"></script> <div class="fb-page" data-href="https://www.facebook.com/thetribune.greenbush.mn/?rf=146220848755581" data-tabs="" data-width="" data-height="" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><blockquote cite="https://www.facebook.com/facebook" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/facebook">Facebook</a></blockquote></div> </aside><aside id="adrotate_widgets-4" class="fl-widget widget_adrotate_widgets"><div class="a-single a-4"><script type="text/javascript" data-params="jsads">
m3ads_system = "MNA";
m3ads_partnernumber = 237166;
m3ads_numberadverts = 1;
m3ads_imagewidth = 300;
m3ads_imageheight = 250;
</script>
<script type="text/javascript" src="//cdn.feed.mna.org/resources/scripts/jsAds-1.4.min.js"></script></div></aside> </div> </div> </div> </div> </div> <footer class="fl-page-footer-wrap" itemscope="itemscope" itemtype="http://schema.org/WPFooter"> <div class="fl-page-footer-widgets"> <div class="fl-page-footer-widgets-container container"> <div class="fl-page-footer-widgets-row row"> <div class="col-sm-4 col-md-4 fl-page-footer-widget-col fl-page-footer-widget-col-1"><aside id="nav_menu-3" class="fl-widget widget_nav_menu"><h4 class="fl-widget-title">Page 1 Publications</h4><div class="menu-footer-menu-1-container"><ul id="menu-footer-menu-1" class="menu"><li id="menu-item-228" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-228"><a href="http://www.page1publications.com/">Home</a></li> <li id="menu-item-22319" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22319"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=1b39bd64-3bf8-4219-b2d6-c49010cd5792">North Star News</a></li> <li id="menu-item-22320" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22320"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=0edf69db-7621-496a-bc5d-30c51d25f9ef">Northern Light Region</a></li> <li id="menu-item-22321" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22321"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=7e6a7f3b-d60a-4328-9883-3a86f55219b7">The Exponent</a></li> <li id="menu-item-22322" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22322"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=bfda4ff1-9fd3-4b96-bfad-af5c10439939">The Tribune</a></li> <li id="menu-item-264337" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-264337"><a target="_blank" rel="noopener noreferrer" href="https://www.newstogo.us/editionviewer/default.aspx?Publication=0e4896ee-3a4d-423f-97fb-dc025cfed655">Supplements</a></li> <li id="menu-item-265748" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-265748"><a target="_blank" rel="noopener noreferrer" href="https://www.newstogo.us/editionviewer/default.aspx?Publication=47737b56-6ab7-4a1b-9649-d73a2ea73970">Lake of the Woods Connection</a></li> <li id="menu-item-21800" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21800"><a href="https://www.page1publications.com/about-us/">About Us</a></li> </ul></div></aside></div><div class="col-sm-4 col-md-4 fl-page-footer-widget-col fl-page-footer-widget-col-2"><aside id="webads_syndicated_stories_menu_widget-2" class="fl-widget widget_webads_syndicated_stories_menu_widget"><h4 class="fl-widget-title">US &#038; World News</h4> <div><ul class="menu"> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.page1publications.com/syndicated_category/united-states/">US</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.page1publications.com/syndicated_category/sports/">Sports</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.page1publications.com/syndicated_category/entertainment/">Entertainment</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.page1publications.com/syndicated_category/technology/">Technology</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.page1publications.com/syndicated_category/political/">Politics</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.page1publications.com/syndicated_category/world/">World</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.page1publications.com/syndicated_category/business/">Business</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.page1publications.com/syndicated_category/health/">Health</a></li> </ul></div> </aside></div><div class="col-sm-4 col-md-4 fl-page-footer-widget-col fl-page-footer-widget-col-3"><aside id="nav_menu-5" class="fl-widget widget_nav_menu"><h4 class="fl-widget-title">Odds &#038; Ends</h4><div class="menu-footer-menu-3-container"><ul id="menu-footer-menu-3" class="menu"><li id="menu-item-216" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-216"><a href="https://www.page1publications.com/crossword/">Crossword Puzzle</a></li> <li id="menu-item-217" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-217"><a href="https://www.page1publications.com/event-calendar/">Event Calendar</a></li> <li id="menu-item-1473" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1473"><a href="https://www.page1publications.com/poll/">Online Poll</a></li> </ul></div></aside></div> </div> </div> </div> <div class="fl-page-footer"> <div class="fl-page-footer-container container"> <div class="fl-page-footer-row row"> <div class="col-md-12 text-center clearfix"><div class="fl-page-footer-text fl-page-footer-text-1">This website is powered by <a href="http://www.websitesfornewspapers.com" target="_blank"><i><strong>WebsitesForNewspapers.com</strong></i></a></div></div> </div> </div> </div> </footer> <script type="text/javascript" >				
				window.addEventListener('DOMContentLoaded', function () {
					setTimeout(function(){
						if( document.querySelectorAll('[name^=ct_checkjs]').length > 0 ) {
			                apbct_public_sendAJAX(
			                    { action: 'apbct_js_keys__get' },
			                    { callback: apbct_js_keys__set_input_value, apbct_ajax: 1 }
			                );
			            }
					},0);					    
				});				
			</script> <script src='https://www.page1publications.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.dyngroup.js' id='adrotate-dyngroup-js'></script> <script src='https://www.google.com/recaptcha/api.js?ver=5.5.6' id='recaptcha-scripts-js'></script> <script id='wp-polls-js-extra'>
var pollsL10n = {"ajax_url":"https:\/\/www.page1publications.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
</script> <script src='https://www.page1publications.com/wp-content/plugins/webads-polls/polls-js.js?ver=2.72' id='wp-polls-js'></script> <script src='https://www.page1publications.com/wp-content/plugins/ecwd-frontend-event-management/js/autocomplete.js?ver=1.0.13' id='sc_form-autocomplete-js'></script> <script src='https://www.page1publications.com/wp-content/plugins/bb-plugin/js/jquery.ba-throttle-debounce.min.js?ver=2.4.2.2' id='jquery-throttle-js'></script> <script src='https://www.page1publications.com/wp-content/plugins/bb-plugin/js/jquery.magnificpopup.min.js?ver=2.4.2.2' id='jquery-magnificpopup-js'></script> <script src='https://www.page1publications.com/wp-content/plugins/bb-plugin/js/jquery.fitvids.min.js?ver=1.2' id='jquery-fitvids-js'></script> <script src='https://www.page1publications.com/wp-includes/js/comment-reply.min.js?ver=5.5.6' id='comment-reply-js'></script> <script src='https://www.page1publications.com/wp-content/themes/bb-theme/js/bootstrap.min.js?ver=1.7.9' id='bootstrap-js'></script> <script id='fl-automator-js-extra'>
var themeopts = {"medium_breakpoint":"992","mobile_breakpoint":"768"};
</script> <script src='https://www.page1publications.com/wp-content/themes/bb-theme/js/theme.min.js?ver=1.7.9' id='fl-automator-js'></script> <script src='https://www.page1publications.com/wp-includes/js/wp-embed.min.js?ver=5.5.6' id='wp-embed-js'></script> <script type="text/javascript">
jQuery(document).ready(function(){if(jQuery.fn.gslider) {
	jQuery('.g-1').gslider({groupid:1,speed:6000,repeat_impressions:'Y'});
	jQuery('.g-3').gslider({groupid:3,speed:6000,repeat_impressions:'Y'});
}});
</script>
</body></html>
<!--
Cached page generated by Borlabs Cache - more information https://borlabs.io/
Time to create cache: 2.27712488 sec
Time to load cache: 0.36454105
Cache file created on: 2021-11-01T14:52:50+00:00
Current time: 2021-11-01T15:50:36+00:00
-->