<!DOCTYPE html>
<html lang="en-US" xmlns:og="http://opengraphprotocol.org/schema/" xmlns:fb="http://www.facebook.com/2008/fbml">
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.page1publications.com/xmlrpc.php" />
<link rel="stylesheet" href="https://www.page1publications.com/wp-content/themes/bb-theme/css/bootstrap.min.css" />
<link rel="stylesheet" href="https://www.page1publications.com/wp-content/themes/bb-theme-child/news01.css" />
<!--[if lt IE 9]>
	<script src="https://www.page1publications.com/wp-content/themes/bb-theme/js/html5shiv.js"></script>
	<script src="https://www.page1publications.com/wp-content/themes/bb-theme/js/respond.min.js"></script>
<![endif]-->
<title>Greenbush Fourth of July Celebration provides days of fun &#8211; Page 1 Publications</title>
    <script>
      var bwg_admin_ajax = 'https://www.page1publications.com/wp-admin/admin-ajax.php?action=shortcode_bwg';
      var bwg_ajax_url = 'https://www.page1publications.com/wp-admin/admin-ajax.php?action';
      var bwg_plugin_url = 'https://www.page1publications.com/wp-content/plugins/photo-gallery';
      document.addEventListener('DOMContentLoaded', function(){ // Analog of $(document).ready(function(){
        bwg_check_ready = function () {}
        document.onkeyup = function(e){
          if ( e.key == 'Escape' ) {
            bwg_remove_loading_block();
          }
        };
      });

      // Set shortcode popup dimensions.
      function bwg_set_shortcode_popup_dimensions() {
        var H = jQuery(window).height(), W = jQuery(window).width();
        jQuery("#TB_title").hide().first().show();
        // New
        var tbWindow = jQuery('#TB_window');
        if (tbWindow.size()) {
          tbWindow.width(W).height(H);
          jQuery('#TB_iframeContent').width(W).height(H);
          tbWindow.attr('style',
            'top:'+ '0px !important;' +
            'left:' + '0px !important;' +
            'margin-left:' + '0;' +
            'z-index:' + '1000500;' +
            'max-width:' + 'none;' +
            'max-height:' + 'none;' +
            '-moz-transform:' + 'none;' +
            '-webkit-transform:' + 'none'
          );
        }
        // Edit
        var tbWindow = jQuery('.mce-window[aria-label="Photo Gallery"]');
        if (tbWindow.length) {
          // To prevent wp centering window with old sizes.
          setTimeout(function() {
            tbWindow.width(W).height(H);
            tbWindow.css({'top': 0, 'left': 0, 'margin-left': '0', 'z-index': '1000500'});
            tbWindow.find('.mce-window-body').width(W).height(H);
          }, 10);
        }
      }
      // Create loading block.
      function bwg_create_loading_block() {
        jQuery('body').append('<div class="loading_div" style="display:block; width: 100%; height: 100%; opacity: 0.6; position: fixed; background-color: #000000; background-image: url('+ bwg_plugin_url +'/images/spinner.gif); background-position: center; background-repeat: no-repeat; background-size: 50px; z-index: 1001000; top: 0; left: 0;"></div>');
      }
      // Remove loading block.
      function bwg_remove_loading_block() {
        jQuery(".loading_div", window.parent.document).remove();
        jQuery('.loading_div').remove();
      }
	  </script>
    <script type="text/javascript" >            function apbct_attach_event_handler__backend(elem, event, callback){                if(typeof window.addEventListener === "function") elem.addEventListener(event, callback);                else                                              elem.attachEvent(event, callback);            }            apbct_attach_event_handler__backend(window, 'load', function(){                ctSetCookie('ct_checkjs', '1637906318' );            });</script><link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Page 1 Publications &raquo; Feed" href="https://www.page1publications.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Page 1 Publications &raquo; Comments Feed" href="https://www.page1publications.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Page 1 Publications &raquo; Greenbush Fourth of July Celebration provides days of fun Comments Feed" href="https://www.page1publications.com/2022/07/08/greenbush-fourth-of-july-celebration-provides-days-of-fun/feed/" />
<meta property="og:title" content="Greenbush Fourth of July Celebration provides days of fun"/><meta property="og:type" content="article"/><meta property="og:url" content="https://www.page1publications.com/2022/07/08/greenbush-fourth-of-july-celebration-provides-days-of-fun/"/><meta property="og:site_name" content="Page 1 Publications"/><meta property="og:image" content="https://www.page1publications.com/wp-content/uploads/2022/07/IMG_0993.jpg"/>		<script>
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.page1publications.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5.9"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style>
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='formidable-css'  href='https://www.page1publications.com/wp-content/plugins/formidable/css/formidableforms.css?ver=910555' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.page1publications.com/wp-includes/css/dist/block-library/style.min.css?ver=5.5.9' media='all' />
<link rel='stylesheet' id='wp-block-library-theme-css'  href='https://www.page1publications.com/wp-includes/css/dist/block-library/theme.min.css?ver=5.5.9' media='all' />
<link rel='stylesheet' id='bwg_fonts-css'  href='https://www.page1publications.com/wp-content/plugins/photo-gallery/css/bwg-fonts/fonts.css?ver=0.0.1' media='all' />
<link rel='stylesheet' id='sumoselect-css'  href='https://www.page1publications.com/wp-content/plugins/photo-gallery/css/sumoselect.min.css?ver=3.0.3' media='all' />
<link rel='stylesheet' id='mCustomScrollbar-css'  href='https://www.page1publications.com/wp-content/plugins/photo-gallery/css/jquery.mCustomScrollbar.min.css?ver=2.5.75' media='all' />
<link rel='stylesheet' id='bwg_frontend-css'  href='https://www.page1publications.com/wp-content/plugins/photo-gallery/css/styles.min.css?ver=2.5.75' media='all' />
<link rel='stylesheet' id='webads-admin-css'  href='https://www.page1publications.com/wp-content/plugins/webads-admin/public/css/webads-admin-public.css?ver=1.2.9' media='all' />
<link rel='stylesheet' id='webads-adrotate-legacy-widget-css'  href='https://www.page1publications.com/wp-content/plugins/webads-adrotate-legacy-widget/public/css/webads-adrotate-legacy-widget-public.css?ver=1.0.0' media='all' />
<link rel='stylesheet' id='webads-adrotate-css'  href='https://www.page1publications.com/wp-content/plugins/webads-adrotate/css/webads-adrotate.css?ver=5.7.02' media='all' />
<link rel='stylesheet' id='webads-church-directory-css'  href='https://www.page1publications.com/wp-content/plugins/webads-church-directory/public/css/webads-church-directory-public.css?ver=1.0.5' media='all' />
<link rel='stylesheet' id='webads-crosswords-css'  href='https://www.page1publications.com/wp-content/plugins/webads-crosswords/public/css/webads-crosswords-public.css?ver=1.0.0' media='all' />
<link rel='stylesheet' id='webads-display-ads-css'  href='https://www.page1publications.com/wp-content/plugins/webads-display-ads/public/css/webads-display-ads-public.css?ver=1.1.5' media='all' />
<link rel='stylesheet' id='webads-elasticpress-css'  href='https://www.page1publications.com/wp-content/plugins/webads-elasticpress/public/css/webads-elasticpress-public.css?ver=1.0.0' media='all' />
<link rel='stylesheet' id='webads-event-calendar-wd-css'  href='https://www.page1publications.com/wp-content/plugins/webads-event-calendar-wd/public/css/webads-event-calendar-wd-public.css?ver=1.0.0' media='all' />
<link rel='stylesheet' id='webads-google-analytics-css'  href='https://www.page1publications.com/wp-content/plugins/webads-google-analytics/public/css/webads-google-analytics-public.css?ver=1.0.0' media='all' />
<link rel='stylesheet' id='webads-htm-classifieds-css'  href='https://www.page1publications.com/wp-content/plugins/webads-htm-classifieds/public/css/webads-htm-classifieds-public.css?ver=1.0.0' media='all' />
<link rel='stylesheet' id='webads-news-ticker-css'  href='https://www.page1publications.com/wp-content/plugins/webads-news-ticker/public/css/webads-news-ticker-public.css?ver=1.0.0' media='all' />
<link rel='stylesheet' id='webads-online-edition-v1-css'  href='https://www.page1publications.com/wp-content/plugins/webads-online-edition-v1/public/css/webads-online-edition-v1-public.css?ver=1.0.3' media='all' />
<link rel='stylesheet' id='webads-paperboy-signup-css'  href='https://www.page1publications.com/wp-content/plugins/webads-paperboy-signup/public/css/webads-paperboy-signup-public.css?ver=1.0.0' media='all' />
<link rel='stylesheet' id='webads-password-protect-css'  href='https://www.page1publications.com/wp-content/plugins/webads-password-protect/public/css/webads-password-protect-public.css?ver=1.0.0' media='all' />
<link rel='stylesheet' id='webads-photo-gallery-css'  href='https://www.page1publications.com/wp-content/plugins/webads-photo-gallery/public/css/webads-photo-gallery-public.css?ver=2.5.40.03' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://www.page1publications.com/wp-content/plugins/webads-polls/polls-css.css?ver=2.72' media='all' />
<style id='wp-polls-inline-css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://www.page1publications.com/wp-content/plugins/webads-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='webads-rss-css'  href='https://www.page1publications.com/wp-content/plugins/webads-rss/public/css/webads-rss-public.css?ver=1.0.0' media='all' />
<link rel='stylesheet' id='webads-social-css'  href='https://www.page1publications.com/wp-content/plugins/webads-social/public/css/webads-social-public.css?ver=5.5.9' media='all' />
<link rel='stylesheet' id='webads-syndicated-stories-css'  href='https://www.page1publications.com/wp-content/plugins/webads-syndicated-stories/public/css/webads-syndicated-stories-public.css?ver=1.0.0' media='all' />
<link rel='stylesheet' id='webads-weather-css'  href='https://www.page1publications.com/wp-content/plugins/webads-weather-v2/public/css/webads-weather-public.css?ver=2.0.7' media='all' />
<link rel='stylesheet' id='ecwd-popup-style-css'  href='https://www.page1publications.com/wp-content/plugins/event-calendar-wd/css/ecwd_popup.css?ver=5.1.32_5956d74b908fe' media='all' />
<link rel='stylesheet' id='ecwd_font-awesome-css'  href='https://www.page1publications.com/wp-content/plugins/event-calendar-wd/css/font-awesome/font-awesome.css?ver=5.1.32_5956d74b908fe' media='all' />
<link rel='stylesheet' id='ecwd-public-css'  href='https://www.page1publications.com/wp-content/plugins/event-calendar-wd/css/style.css?ver=5.1.32_5956d74b908fe' media='all' />
<link rel='stylesheet' id='sc_form-add_event_public-css'  href='https://www.page1publications.com/wp-content/plugins/ecwd-frontend-event-management/css/style.css?ver=1.0.13' media='all' />
<link rel='stylesheet' id='addtoany-css'  href='https://www.page1publications.com/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' media='all' />
<link rel='stylesheet' id='jquery-magnificpopup-css'  href='https://www.page1publications.com/wp-content/plugins/bb-plugin/css/jquery.magnificpopup.min.css?ver=2.4.2.2' media='all' />
<link rel='stylesheet' id='bootstrap-css'  href='https://www.page1publications.com/wp-content/themes/bb-theme/css/bootstrap.min.css?ver=1.7.9' media='all' />
<link rel='stylesheet' id='fl-automator-skin-css'  href='https://www.page1publications.com/wp-content/uploads/bb-theme/skin-626aa71f86987.css?ver=1.7.9' media='all' />
<link rel='stylesheet' id='fl-builder-google-fonts-3f19d897d5677fab9c7f938fa02ecdad-css'  href='//fonts.googleapis.com/css?family=Oswald%3A400&#038;ver=5.5.9' media='all' />
<script src='https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js?ver=1.12.4' id='jquery-js'></script>
<script src='https://www.page1publications.com/wp-content/plugins/event-calendar-wd/js/gmap/gmap3.js?ver=5.1.32_5956d74b908fe' id='ecwd-gmap-public-js'></script>
<script src='https://www.page1publications.com/wp-content/plugins/event-calendar-wd/js/ecwd_popup.js?ver=5.1.32_5956d74b908fe' id='ecwd-popup-js'></script>
<script src='https://www.page1publications.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4' id='jquery-ui-core-js'></script>
<script src='https://www.page1publications.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4' id='jquery-ui-widget-js'></script>
<script src='https://www.page1publications.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4' id='jquery-ui-mouse-js'></script>
<script src='https://www.page1publications.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4' id='jquery-ui-draggable-js'></script>
<script src='https://www.page1publications.com/wp-includes/js/imagesloaded.min.js?ver=5.5.9' id='imagesloaded-js'></script>
<script src='https://www.page1publications.com/wp-includes/js/masonry.min.js?ver=4.2.2' id='masonry-js'></script>
<script id='ecwd-public-js-extra'>
var ecwd = {"ajaxurl":"https:\/\/www.page1publications.com\/wp-admin\/admin-ajax.php","ajaxnonce":"4645269fa3","loadingText":"Loading...","event_popup_title_text":"Event Details","plugin_url":"https:\/\/www.page1publications.com\/wp-content\/plugins\/event-calendar-wd","gmap_type":"ROADMAP","gmap_redirect":"","gmap_key":"AIzaSyCaa0RtTxnqA-JnjHxBpIGMd3YpYmbJm8g","gmap_style":""};
</script>
<script src='https://www.page1publications.com/wp-content/plugins/event-calendar-wd/js/scripts.js?ver=5.1.32_5956d74b908fe' id='ecwd-public-js'></script>
<script src='https://www.page1publications.com/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1' id='addtoany-js'></script>
<script id='ct_public-js-extra'>
var ctPublic = {"_ajax_nonce":"25ddf0a714","_rest_nonce":"e7325cb5c4","_ajax_url":"\/wp-admin\/admin-ajax.php","_rest_url":"https:\/\/www.page1publications.com\/wp-json\/","_apbct_ajax_url":"https:\/\/www.page1publications.com\/wp-content\/plugins\/cleantalk-spam-protect\/lib\/Cleantalk\/ApbctWP\/Ajax.php","data__set_cookies":"1","data__set_cookies__alt_sessions_type":"0","pixel__setting":"0","pixel__enabled":"","pixel__url":null,"data__email_check_before_post":"1"};
</script>
<script src='https://www.page1publications.com/wp-content/plugins/cleantalk-spam-protect/js/apbct-public.min.js?apbct_ver=5.159.5&#038;ver=5.159.5' id='ct_public-js'></script>
<script src='https://www.page1publications.com/wp-content/plugins/cleantalk-spam-protect/js/cleantalk-modal.min.js?ver=5.159.5' id='cleantalk-modal-js'></script>
<script id='ct_nocache-js-extra'>
var ctNocache = {"ajaxurl":"\/wp-admin\/admin-ajax.php","info_flag":"","set_cookies_flag":"1","blog_home":"https:\/\/www.page1publications.com\/"};
</script>
<script src='https://www.page1publications.com/wp-content/plugins/cleantalk-spam-protect/js/cleantalk_nocache.min.js?ver=5.159.5' id='ct_nocache-js'></script>
<script src='https://www.page1publications.com/wp-content/plugins/photo-gallery/js/jquery.sumoselect.min.js?ver=3.0.3' id='sumoselect-js'></script>
<script src='https://www.page1publications.com/wp-content/plugins/photo-gallery/js/jquery.mobile.min.js?ver=1.4.5' id='jquery-mobile-js'></script>
<script src='https://www.page1publications.com/wp-content/plugins/photo-gallery/js/jquery.mCustomScrollbar.concat.min.js?ver=2.5.75' id='mCustomScrollbar-js'></script>
<script src='https://www.page1publications.com/wp-content/plugins/photo-gallery/js/jquery.fullscreen-0.4.1.min.js?ver=0.4.1' id='jquery-fullscreen-js'></script>
<script id='bwg_frontend-js-extra'>
var bwg_objectsL10n = {"bwg_field_required":"field is required.","bwg_mail_validation":"This is not a valid email address.","bwg_search_result":"There are no images matching your search.","bwg_select_tag":"Select Tag","bwg_order_by":"Order By","bwg_search":"Search","bwg_show_ecommerce":"Show Ecommerce","bwg_hide_ecommerce":"Hide Ecommerce","bwg_show_comments":"Show Comments","bwg_hide_comments":"Hide Comments","bwg_restore":"Restore","bwg_maximize":"Maximize","bwg_fullscreen":"Fullscreen","bwg_exit_fullscreen":"Exit Fullscreen","bwg_search_tag":"SEARCH...","bwg_tag_no_match":"No tags found","bwg_all_tags_selected":"All tags selected","bwg_tags_selected":"tags selected","play":"Play","pause":"Pause","is_pro":"1","bwg_play":"Play","bwg_pause":"Pause","bwg_hide_info":"Hide info","bwg_show_info":"Show info","bwg_hide_rating":"Hide rating","bwg_show_rating":"Show rating","ok":"Ok","cancel":"Cancel","select_all":"Select all","lazy_load":"0","lazy_loader":"https:\/\/www.page1publications.com\/wp-content\/plugins\/photo-gallery\/images\/ajax_loader.png","front_ajax":"0","bwg_tag_see_all":"see all tags","bwg_tag_see_less":"see less tags"};
</script>
<script src='https://www.page1publications.com/wp-content/plugins/photo-gallery/js/scripts.min.js?ver=2.5.75' id='bwg_frontend-js'></script>
<script src='https://www.page1publications.com/wp-content/plugins/webads-admin/public/js/webads-admin-public.js?ver=1.2.9' id='webads-admin-js'></script>
<script src='https://www.page1publications.com/wp-content/plugins/webads-adrotate-legacy-widget/public/js/webads-adrotate-legacy-widget-public.js?ver=1.0.0' id='webads-adrotate-legacy-widget-js'></script>
<script src='https://www.page1publications.com/wp-content/plugins/webads-church-directory/public/js/webads-church-directory-public.js?ver=1.0' id='webads-church-directory-js'></script>
<script src='https://www.page1publications.com/wp-content/plugins/webads-crosswords/public/js/webads-crosswords-public.js?ver=1.0.0' id='webads-crosswords-js'></script>
<script src='https://www.page1publications.com/wp-content/plugins/webads-display-ads/public/js/jquery.sudoSlider.js?ver=1.0.0' id='webads-display-ads-js'></script>
<script src='https://www.page1publications.com/wp-content/plugins/webads-elasticpress/public/js/webads-elasticpress-public.js?ver=1.0.0' id='webads-elasticpress-js'></script>
<script src='https://www.page1publications.com/wp-content/plugins/webads-event-calendar-wd/public/js/webads-event-calendar-wd-public.js?ver=1.0.0' id='webads-event-calendar-wd-js'></script>
<script src='https://www.page1publications.com/wp-content/plugins/webads-google-analytics/public/js/webads-google-analytics-public.js?ver=1.0.0' id='webads-google-analytics-js'></script>
<script src='https://www.page1publications.com/wp-content/plugins/webads-htm-classifieds/public/js/webads-htm-classifieds-public.js?ver=1.0.0' id='webads-htm-classifieds-js'></script>
<script src='https://www.page1publications.com/wp-content/plugins/webads-news-ticker/public/js/webads-news-ticker-public.js?ver=23' id='webads-news-ticker-js'></script>
<script src='https://www.page1publications.com/wp-content/plugins/webads-online-edition-v1/public/js/webads-online-edition-v1-public.js?ver=1.0.3' id='webads-online-edition-v1-js'></script>
<script src='https://www.page1publications.com/wp-content/plugins/webads-paperboy-signup/public/js/webads-paperboy-signup-public.js?ver=1.0.0' id='webads-paperboy-signup-js'></script>
<script src='https://www.page1publications.com/wp-content/plugins/webads-password-protect/public/js/webads-password-protect-public.js?ver=1.0.0' id='webads-password-protect-js'></script>
<script src='https://www.page1publications.com/wp-content/plugins/webads-password-protect/public/js/js.cookie.min.js?ver=5.5.9' id='jquery-cookie-js'></script>
<script src='https://www.page1publications.com/wp-content/plugins/webads-photo-gallery/public/js/webads-photo-gallery-public.js?ver=2.5.40.03' id='webads-photo-gallery-js'></script>
<script src='https://www.page1publications.com/wp-content/plugins/webads-rss/public/js/webads-rss-public.js?ver=1.0.0' id='webads-rss-js'></script>
<script src='https://www.page1publications.com/wp-content/plugins/webads-social/public/js/webads-social-public.js?ver=0.0.1' id='webads-social-js'></script>
<script src='https://www.page1publications.com/wp-content/plugins/webads-syndicated-stories/public/js/webads-syndicated-stories-public.js?ver=1.0.1' id='webads-syndicated-stories-js'></script>
<script src='https://www.page1publications.com/wp-content/plugins/webads-weather-v2/public/js/webads-weather-public.js?ver=2.0.8' id='webads-weather-js'></script>
<link rel="https://api.w.org/" href="https://www.page1publications.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.page1publications.com/wp-json/wp/v2/posts/268068" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.page1publications.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.page1publications.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='GREENBUSH MIDDLE RIVER SCHOOL (Minn.) Proceedings May 16, 2022' href='https://www.page1publications.com/2022/07/05/greenbush-middle-river-school-minn-proceedings-may-16-2022/' />
<meta name="generator" content="WordPress 5.5.9" />
<link rel="canonical" href="https://www.page1publications.com/2022/07/08/greenbush-fourth-of-july-celebration-provides-days-of-fun/" />
<link rel='shortlink' href='https://www.page1publications.com/?p=268068' />
<link rel="alternate" type="application/json+oembed" href="https://www.page1publications.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.page1publications.com%2F2022%2F07%2F08%2Fgreenbush-fourth-of-july-celebration-provides-days-of-fun%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.page1publications.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.page1publications.com%2F2022%2F07%2F08%2Fgreenbush-fourth-of-july-celebration-provides-days-of-fun%2F&#038;format=xml" />

<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>

<!-- This site is using AdRotate v5.8.3 Professional to display their advertisements - https://ajdg.solutions/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { margin:0px 0px 0px 0px;width:100%; max-width:300px; height:100%; max-height:250px; }
	.g-3 { margin:0px 0px 0px 0px;width:100%; max-width:100px; height:100%; max-height:100px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<script type="text/javascript">document.documentElement.className += " js";</script>
<link rel="shortcut icon" href="https://www.page1publications.com/wp-content/uploads/2021/03/favicon-16x16-1.png"/>


<script>
    (function (i, s, o, g, r, a, m) {
      i['GoogleAnalyticsObject'] = r;
      i[r] = i[r] || function () {
          (i[r].q = i[r].q || []).push(arguments)
      }, i[r].l = 1 * new Date();
      a = s.createElement(o),
          m = s.getElementsByTagName(o)[0];
      a.async = 1;
      a.src = g;
      m.parentNode.insertBefore(a, m)
  })
  (window, document, 'script', '//www.google-analytics.com/analytics.js', 'ga');
  ga('create', 'UA-36148557-31', 'auto', {
      'siteSpeedSampleRate': '1'   });
    ga('send', 'pageview');
  </script><link rel="stylesheet" href="https://www.page1publications.com/wp-content/themes/bb-theme-child/style.css" /></head>

<body data-rsssl=1 class="post-template-default single single-post postid-268068 single-format-standard ecwd-theme-parent-bb-theme ecwd-theme-child-bb-theme-child fl-framework-bootstrap fl-preset-color01 fl-fixed-width fl-has-sidebar" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/21843165966/Page_1_Publications_DY', [728, 90], 'div-gpt-ad-1611788603323-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script><a aria-label="Skip to content" class="fl-screen-reader-text" href="#fl-main-content">Skip to content</a><div>
	<div class="fl-page-bar">
	<div class="fl-page-bar-container container">
		<div class="fl-page-bar-row row">
			<div class="col-md-8 hidden-sm text-left clearfix">		<div class="breakingNews" id="bn7">
			<div class="bn-title"><h2>Breaking News</h2><span></span></div>
			<ul>
								<li><a href="https://www.page1publications.com/2022/07/08/greenbush-fourth-of-july-celebration-provides-days-of-fun/">Greenbush Fourth of July Celebration provides days of fun</a></li>
								<li><a href="https://www.page1publications.com/2022/07/04/achievement-rooted-in-family-tradition/">Achievement rooted in family tradition</a></li>
								<li><a href="https://www.page1publications.com/2022/06/30/finding-a-home-on-the-softball-diamond-former-gator-missy-bruggeman-named-to-minnesota-softball-hall-of-fame/">Finding a home on the softball diamond Former: Gator Missy Bruggeman named to Minnesota Softball Hall of Fame</a></li>
								<li><a href="https://www.page1publications.com/2022/06/23/three-gator-golfers-conclude-season-at-state/">Three Gator golfers conclude season at state</a></li>
								<li><a href="https://www.page1publications.com/2022/06/17/bgmr-freeze-athletes-battle-at-state-track-and-field-meet-skeim-captures-sixth-place-state-finish/">BGMR/Freeze athletes battle at state track and field meet: Skeim captures sixth place state finish</a></li>
								<li><a href="https://www.page1publications.com/2022/06/13/june-13-lake-of-the-woods-mn-fishing-report/">June 13 Lake of the Woods MN Fishing Report</a></li>
								<li><a href="https://www.page1publications.com/2022/06/10/alleged-1-man-polk-county-crime-wave/">Alleged, 1 Man, Polk County Crime Wave</a></li>
								<li><a href="https://www.page1publications.com/2022/06/10/update-suspect-who-jumped-in-river-following-egf-pursuit-identified/">UPDATE: Suspect Who Jumped In River Following EGF Pursuit Identified</a></li>
								<li><a href="https://www.page1publications.com/2022/06/10/wagon-wheel-ridge-expanding-to-accommodate-upcoming-festivals/">Wagon Wheel Ridge expanding to accommodate upcoming festivals</a></li>
								<li><a href="https://www.page1publications.com/2022/06/10/three-gator-golfers-advance-to-state/">Three Gator golfers advance to state</a></li>
				
			</ul>
			<div class="bn-navi">
				<span></span>
				<span></span>
			</div>
	</div>
        
<script>
    (function( $ ) {
        $(window).load(function(e) {

            $("#bn7").breakingNews({
                effect		:"slide-v",
                autoplay	:true,
                timer		:7000,
                color		:'default'
            });

        });

    })( jQuery );
</script>

<div class="fl-page-bar-text fl-page-bar-text-1"></div></div>			<div class="col-md-4 col-sm-12 text-right clearfix"><ul id="menu-top-bar-menu" class="fl-page-bar-nav nav navbar-nav menu"><li id="menu-item-20756" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-20756 nav-item"><a href="#" class="nav-link">Contact Us</a>
<ul class="sub-menu">
	<li id="menu-item-284" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-284 nav-item"><a href="https://www.page1publications.com/contact-us/" class="nav-link">The Exponent</a></li>
	<li id="menu-item-20757" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20757 nav-item"><a href="https://www.page1publications.com/contact-us-north-star-news/" class="nav-link">North Star News</a></li>
	<li id="menu-item-20758" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20758 nav-item"><a href="https://www.page1publications.com/contact-us-the-tribune/" class="nav-link">The Tribune</a></li>
	<li id="menu-item-20759" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20759 nav-item"><a href="https://www.page1publications.com/contact-us-northern-light-region/" class="nav-link">The Northern Light</a></li>
</ul>
</li>
<li id="menu-item-21799" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21799 nav-item"><a href="https://www.page1publications.com/about-us/" class="nav-link">About Us</a></li>
<li id="menu-item-285" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-285 nav-item"><a class="nav-link">E-Editions</a>
<ul class="sub-menu">
	<li id="menu-item-22331" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22331 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=1b39bd64-3bf8-4219-b2d6-c49010cd5792" class="nav-link">North Star News</a></li>
	<li id="menu-item-22332" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22332 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=0edf69db-7621-496a-bc5d-30c51d25f9ef" class="nav-link">Northern Light Region</a></li>
	<li id="menu-item-22333" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22333 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=7e6a7f3b-d60a-4328-9883-3a86f55219b7" class="nav-link">The Exponent</a></li>
	<li id="menu-item-22334" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22334 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=bfda4ff1-9fd3-4b96-bfad-af5c10439939" class="nav-link">The Tribune</a></li>
	<li id="menu-item-264334" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-264334 nav-item"><a target="_blank" rel="noopener noreferrer" href="https://www.newstogo.us/editionviewer/default.aspx?Publication=0e4896ee-3a4d-423f-97fb-dc025cfed655" class="nav-link">Supplements</a></li>
	<li id="menu-item-265750" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-265750 nav-item"><a target="_blank" rel="noopener noreferrer" href="https://www.newstogo.us/editionviewer/default.aspx?Publication=47737b56-6ab7-4a1b-9649-d73a2ea73970" class="nav-link">Lake of the Woods Connection</a></li>
</ul>
</li>
<li id="menu-item-286" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-286 nav-item"><a class="nav-link">Subscribe</a>
<ul class="sub-menu">
	<li id="menu-item-22335" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22335 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=1b39bd64-3bf8-4219-b2d6-c49010cd5792&#038;view=subscribe" class="nav-link">North Star News</a></li>
	<li id="menu-item-22336" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22336 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=0edf69db-7621-496a-bc5d-30c51d25f9ef&#038;view=subscribe" class="nav-link">Northern Light Region</a></li>
	<li id="menu-item-22337" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22337 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=7e6a7f3b-d60a-4328-9883-3a86f55219b7&#038;view=subscribe" class="nav-link">The Exponent</a></li>
	<li id="menu-item-22338" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22338 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=bfda4ff1-9fd3-4b96-bfad-af5c10439939&#038;view=subscribe" class="nav-link">The Tribune</a></li>
</ul>
</li>
<li id="menu-item-287" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-287 nav-item"><a class="nav-link">Archives</a>
<ul class="sub-menu">
	<li id="menu-item-22339" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22339 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=1b39bd64-3bf8-4219-b2d6-c49010cd5792&#038;view=archives" class="nav-link">North Star News</a></li>
	<li id="menu-item-22340" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22340 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=0edf69db-7621-496a-bc5d-30c51d25f9ef&#038;view=archives" class="nav-link">Northern Light Region</a></li>
	<li id="menu-item-22341" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22341 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=7e6a7f3b-d60a-4328-9883-3a86f55219b7&#038;view=archives" class="nav-link">The Exponent</a></li>
	<li id="menu-item-22342" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22342 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=bfda4ff1-9fd3-4b96-bfad-af5c10439939&#038;view=archives" class="nav-link">The Tribune</a></li>
	<li id="menu-item-264335" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-264335 nav-item"><a target="_blank" rel="noopener noreferrer" href="https://www.newstogo.us/editionviewer/default.aspx?Publication=0e4896ee-3a4d-423f-97fb-dc025cfed655&#038;view=archives" class="nav-link">Supplements</a></li>
</ul>
</li>
</ul>	<div class="fl-social-icons">
	<a href="https://www.facebook.com/Northern-Light-Region-123704497685047/" target="_blank" rel="noopener noreferrer"><span class="sr-only">Facebook</span><i aria-hidden="true" class="fab fa-facebook-f mono"></i></a><a href="mailto:rolly@wiktel.com" rel="noopener noreferrer"><span class="sr-only">Email</span><i aria-hidden="true" class="fas fa-envelope mono"></i></a></div>
</div>		</div>
	</div>
</div><!-- .fl-page-bar -->
</div>
<div class="fl-page">
	<header class="fl-page-header fl-page-header-primary fl-page-nav-bottom fl-page-nav-toggle-button fl-page-nav-toggle-visible-mobile" itemscope="itemscope"
        itemtype="http://schema.org/WPHeader">
    <div class="fl-page-header-wrap">

                    <div class="fl-page-header-container container">
                <div class="fl-page-header-row row">
                    <div class="col-md-8 col-sm-8">
                        <div class="fl-page-header-logo" itemscope="itemscope"
                             itemtype="http://schema.org/Organization">
                            <a href="https://www.page1publications.com" itemprop="url"><img loading="false" data-no-lazy="1" class="fl-logo-img" itemscope itemtype="https://schema.org/ImageObject" src="https://www.page1publications.com/wp-content/uploads/2021/01/header.png" data-retina="" title="" alt="Page 1 Publications" /><meta itemprop="name" content="Page 1 Publications" /></a>
                        </div>
                    </div>
                    <div class="col-md-4 col-sm-4">
                        <div class="fl-page-header-content">
                            <div id="webads_weather_widget-2" class="widget widget_webads_weather_widget pull-right">
        <script>
            jQuery(document).ready(function() {
                loadWeather('56721', 'transparent', 'East Grand Forks', '56721');
            });
        </script>

        <div id="webads-weather-56721" class="widget widget-webads-weather">
            <a id="webads-weather-56721-link" href="https://www.page1publications.com">
                <div class="awe-mini">
                    <div>
                        <div class="col visual">
                            <span id="webads-weather-56721-temperature" class="temperature"></span>
                            <i id="webads-weather-56721-image" class="weather-forecast-icon" style="background-size:contain"></i>
                        </div>
                        <div class="col info">
                            <span id="webads-weather-56721-location" class="location"></span>
                            <span id="webads-weather-56721-conditions" class="forecast"></span>
                        </div>
                    </div>
                </div>
            </a>
        </div>

        <script>
            function loadWeather(zipcode, background, location, instanceid) {
                if (zipcode !== undefined) {
                    var location = String(location);
                    var instanceid = String(instanceid);
                    jQuery.ajax({
                        url: "https://ws.iadsnetwork.com/weather.svc/GetCurrentConditions",
                        data: { "zipcode": zipcode },
                        dataType: "json",
                        type: "GET",
                        contentType: "application/json; charset=utf-8",
                        success: function (data) {
                            if (data.d != null) {
                                var dtCC = data.d;
                                for (i = 0; i < dtCC.length; i++) {
                                    jQuery("#webads-weather-" + instanceid + "-temperature").append(dtCC[i].temperature);
                                    jQuery("#webads-weather-" + instanceid + "-location").append(location);
                                    jQuery("#webads-weather-" + instanceid + "-conditions").append(dtCC[i].conditions);
                                    jQuery("#webads-weather-" + instanceid + "-image").css('background-image', 'url(' + dtCC[i].image + ')');
                                    $link = jQuery("#webads-weather-" + instanceid + "-link").attr("href");
                                    jQuery("#webads-weather-" + instanceid + "-link").attr("href", $link + '/weather/?zipcode=' + dtCC[i].zipcode + '&location=' + encodeURIComponent(location));
                                    jQuery("#webads-weather-" + instanceid).css('background-color', background);
                                }
                            }
                        },
                        error: function (d) {
                            //alert("Error");
                        }
                    });
                }
            }
        </script>

        </div><div id="search-2" class="widget widget_search pull-right"><form aria-label="Search" method="get" role="search" action="https://www.page1publications.com/" title="Type and press Enter to search.">
	<input aria-label="Search" type="search" class="fl-search-input form-control" name="s" placeholder="Search"  value="" onfocus="if (this.value === 'Search') { this.value = ''; }" onblur="if (this.value === '') this.value='Search';" />
</form>
</div>                        </div>
                    </div>
                </div>
            </div>
            
    </div>
    <div class="fl-page-nav-wrap">
        <div class="fl-page-nav-container container">
            <nav class="fl-page-nav navbar navbar-default" role="navigation" itemscope="itemscope"
                 itemtype="http://schema.org/SiteNavigationElement">
                <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".fl-page-nav-collapse">
                    <span>Menu</span>
                </button>
                <div class="fl-page-nav-collapse collapse navbar-collapse">
                    <ul id="menu-main-menu" class="nav navbar-nav menu"><li id="menu-item-1076" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-1076 nav-item"><a href="https://www.page1publications.com/" class="nav-link">Home</a></li>
<li id="menu-item-296" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-296 nav-item"><a class="nav-link">E-Editions</a>
<ul class="sub-menu">
	<li id="menu-item-22323" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22323 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=1b39bd64-3bf8-4219-b2d6-c49010cd5792" class="nav-link">North Star News</a></li>
	<li id="menu-item-22324" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22324 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=0edf69db-7621-496a-bc5d-30c51d25f9ef" class="nav-link">Northern Light Region</a></li>
	<li id="menu-item-22325" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22325 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=7e6a7f3b-d60a-4328-9883-3a86f55219b7" class="nav-link">The Exponent</a></li>
	<li id="menu-item-22326" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22326 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=bfda4ff1-9fd3-4b96-bfad-af5c10439939" class="nav-link">The Tribune</a></li>
	<li id="menu-item-264333" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-264333 nav-item"><a target="_blank" rel="noopener noreferrer" href="https://www.newstogo.us/editionviewer/default.aspx?Publication=0e4896ee-3a4d-423f-97fb-dc025cfed655" class="nav-link">Supplements</a></li>
	<li id="menu-item-265749" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-265749 nav-item"><a target="_blank" rel="noopener noreferrer" href="https://www.newstogo.us/editionviewer/default.aspx?Publication=47737b56-6ab7-4a1b-9649-d73a2ea73970" class="nav-link">Lake of the Woods Connection</a></li>
</ul>
</li>
<li id="menu-item-297" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-297 nav-item"><a class="nav-link">Subscribe</a>
<ul class="sub-menu">
	<li id="menu-item-22327" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22327 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=1b39bd64-3bf8-4219-b2d6-c49010cd5792&#038;view=subscribe" class="nav-link">North Star News</a></li>
	<li id="menu-item-22328" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22328 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=0edf69db-7621-496a-bc5d-30c51d25f9ef&#038;view=subscribe" class="nav-link">Northern Light Region</a></li>
	<li id="menu-item-22329" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22329 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=7e6a7f3b-d60a-4328-9883-3a86f55219b7&#038;view=subscribe" class="nav-link">The Exponent</a></li>
	<li id="menu-item-22330" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22330 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=bfda4ff1-9fd3-4b96-bfad-af5c10439939&#038;view=subscribe" class="nav-link">The Tribune</a></li>
</ul>
</li>
<li id="menu-item-30182" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30182 nav-item"><a href="https://www.page1publications.com/category/public-notices/" class="nav-link">Public Notices</a></li>
<li id="menu-item-292" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-292 nav-item"><a href="https://www.page1publications.com/obituaries/" class="nav-link">Obits</a></li>
<li id="menu-item-4243" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-4243 nav-item"><a href="#" class="nav-link">Regional News</a>
<ul class="sub-menu">
	<li id="menu-item-4246" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4246 nav-item"><a href="https://www.page1publications.com/arkansas-news/" class="nav-link">Minnesota News</a></li>
	<li id="menu-item-4245" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4245 nav-item"><a href="https://www.page1publications.com/east-grand-fork-green-wave-news/" class="nav-link">East Grand Fork Green Wave News</a></li>
	<li id="menu-item-4244" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4244 nav-item"><a href="https://www.page1publications.com/fort-smith-news/" class="nav-link">St. Paul News</a></li>
</ul>
</li>
<li id="menu-item-21777" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-21777 nav-item"><a href="#" class="nav-link">Connect</a>
<ul class="sub-menu">
	<li id="menu-item-21776" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21776 nav-item"><a href="https://www.page1publications.com/community-links/" class="nav-link">Community Links</a></li>
	<li id="menu-item-290" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-290 nav-item"><a href="https://www.page1publications.com/event-calendar/" class="nav-link">Events</a></li>
	<li id="menu-item-289" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-289 nav-item"><a href="https://www.page1publications.com/crossword/" class="nav-link">Crossword</a></li>
</ul>
</li>
<li id="menu-item-20879" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-20879 nav-item"><a href="#" class="nav-link">Meet the Folks at:</a>
<ul class="sub-menu">
	<li id="menu-item-20875" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20875 nav-item"><a href="https://www.page1publications.com/meet-the-folks-at-the-exponent/" class="nav-link">The Exponent</a></li>
	<li id="menu-item-20876" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20876 nav-item"><a href="https://www.page1publications.com/20768-2/" class="nav-link">The Tribune</a></li>
	<li id="menu-item-20877" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20877 nav-item"><a href="https://www.page1publications.com/meet-the-folks-at-north-star-news/" class="nav-link">North Star News</a></li>
	<li id="menu-item-20878" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20878 nav-item"><a href="https://www.page1publications.com/20761-2/" class="nav-link">The Northern Light</a></li>
</ul>
</li>
<li id="menu-item-21769" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-21769 nav-item"><a href="#" class="nav-link">Our Newspaper History</a>
<ul class="sub-menu">
	<li id="menu-item-21770" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21770 nav-item"><a href="https://www.page1publications.com/the-history-of-the-exponent/" class="nav-link">The Exponent</a></li>
	<li id="menu-item-21771" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21771 nav-item"><a href="https://www.page1publications.com/21764-2/" class="nav-link">The Tribune</a></li>
	<li id="menu-item-21772" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21772 nav-item"><a href="https://www.page1publications.com/the-history-of-north-star-news/" class="nav-link">North Star News</a></li>
	<li id="menu-item-21773" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21773 nav-item"><a href="https://www.page1publications.com/history-of-the-northern-light-region/" class="nav-link">The Northern Light Region</a></li>
</ul>
</li>
<li id="menu-item-260872" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-260872 nav-item"><a href="https://www.page1publications.com/category/news/" class="nav-link">News</a></li>
</ul>                </div>
            </nav>
        </div>
    </div>
</header><!-- .fl-page-header -->	<div class="fl-page-content" itemprop="mainContentOfPage">
        <div class="webads-userbar-wrapper" style="display: none;"><span class="webads-userbar"><span class="webads-userbar-name"></span><span class="fl-sep"> | </span><a href="https://www.page1publications.com/wp-admin/admin-post.php?action=webads_logout&webads_logout_nonce=DS9URN7DtQcxre6U"><span>logout</span></a></span></div>        <script>
            $(document).ready(function(){
                if (Cookies.get('webads-auth-1811')) {
                    $(".webads-userbar-wrapper").show();
                    $(".webads-userbar-name").text(decodeURIComponent(Cookies.get('webads-username-1811')));
                } else {
                    $(".webads-userbar-wrapper").hide();
                }
            });
        </script>

		
<div class="container">
	<div class="row">

		
		<div class="fl-content fl-content-left col-md-9">
			<article class="fl-post post-268068 post type-post status-publish format-standard has-post-thumbnail hentry category-breaking-news category-news" id="fl-post-268068" itemscope="itemscope"
                                         itemtype="http://schema.org/BlogPosting">

    <header class="fl-post-header">
        <h1 class="fl-post-title" itemprop="headline">
            Greenbush Fourth of July Celebration provides days of fun                    </h1>
        <div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author" itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person">By <a href="https://www.page1publications.com/author/editor/" itemprop="url"><span itemprop="name">Editor</span></a></span><span class="fl-sep"> | </span><span class="fl-post-date" itemprop="datePublished" datetime="2022-07-08">July 8, 2022</span><span class="fl-sep"> | </span><span class="fl-comments-popup-link"><a href="https://www.page1publications.com/2022/07/08/greenbush-fourth-of-july-celebration-provides-days-of-fun/#respond" tabindex="-1" aria-hidden="true">0 <i class="fa fa-comment"></i></a></span></div><meta itemprop="image" content="https://www.page1publications.com/wp-content/uploads/2022/07/IMG_0993.jpg"><meta itemprop="interactionCount" content="UserComments:0">    </header><!-- .fl-post-header -->

    
    
            <div class="fl-post-content clearfix" itemprop="text">
                <p><!-- /21843165966/Page_1_Publications_DY --></p>
<div id="div-gpt-ad-1611788603323-0"><script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1611788603323-0'); });
  </script></div>
<p>&nbsp;</p>
<div style="height: 7px;"></div>
<div id="attachment_268069" style="width: 910px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-268069" loading="lazy" src="https://www.page1publications.com/wp-content/uploads/2022/07/IMG_0993.jpg" alt="" width="900" height="1200" class="size-full wp-image-268069" srcset="https://www.page1publications.com/wp-content/uploads/2022/07/IMG_0993.jpg 900w, https://www.page1publications.com/wp-content/uploads/2022/07/IMG_0993-225x300.jpg 225w, https://www.page1publications.com/wp-content/uploads/2022/07/IMG_0993-768x1024.jpg 768w" sizes="(max-width: 900px) 100vw, 900px" /><p id="caption-attachment-268069" class="wp-caption-text">photo by Ryan Bergeron<br />Various colors lit up the night sky above Borgen Field as part of the fireworks show in Greenbush on July 2.</p></div>
<div id="attachment_268070" style="width: 1210px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-268070" loading="lazy" src="https://www.page1publications.com/wp-content/uploads/2022/07/IMG_0911.jpg" alt="" width="1200" height="900" class="size-full wp-image-268070" srcset="https://www.page1publications.com/wp-content/uploads/2022/07/IMG_0911.jpg 1200w, https://www.page1publications.com/wp-content/uploads/2022/07/IMG_0911-300x225.jpg 300w, https://www.page1publications.com/wp-content/uploads/2022/07/IMG_0911-1024x768.jpg 1024w, https://www.page1publications.com/wp-content/uploads/2022/07/IMG_0911-768x576.jpg 768w" sizes="(max-width: 1200px) 100vw, 1200px" /><p id="caption-attachment-268070" class="wp-caption-text">photo by Ryan Bergeron<br />Lisa Bergsnev, Danielle Berg, Jordan Creviston, Lisa Careme, and Jody Kirkeide of Border Bank served root beer floats on July 1 in the Border Bank parking lot in Greenbush.</p></div>
<div id="attachment_268071" style="width: 1210px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-268071" loading="lazy" src="https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0818.jpg" alt="" width="1200" height="796" class="size-full wp-image-268071" srcset="https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0818.jpg 1200w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0818-300x199.jpg 300w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0818-1024x679.jpg 1024w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0818-768x509.jpg 768w" sizes="(max-width: 1200px) 100vw, 1200px" /><p id="caption-attachment-268071" class="wp-caption-text">photo by Ryan Bergeron<br />Christian Berg gets some air time during a Junior race at the Greenbush Motocross Track on July 4, finishing first in the heat race.</p></div>
<div id="attachment_268072" style="width: 1210px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-268072" loading="lazy" src="https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0782.jpg" alt="" width="1200" height="796" class="size-full wp-image-268072" srcset="https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0782.jpg 1200w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0782-300x199.jpg 300w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0782-1024x679.jpg 1024w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0782-768x509.jpg 768w" sizes="(max-width: 1200px) 100vw, 1200px" /><p id="caption-attachment-268072" class="wp-caption-text">photo by Ryan Bergeron<br />Christian Berg gets some air time during a Junior race at the Greenbush Motocross Track on July 4, finishing first in the heat race.</p></div>
<div id="attachment_268073" style="width: 1210px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-268073" loading="lazy" src="https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0751.jpg" alt="" width="1200" height="796" class="size-full wp-image-268073" srcset="https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0751.jpg 1200w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0751-300x199.jpg 300w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0751-1024x679.jpg 1024w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0751-768x509.jpg 768w" sizes="(max-width: 1200px) 100vw, 1200px" /><p id="caption-attachment-268073" class="wp-caption-text">photo by Ryan Bergeron<br />Faith Novacek drives Ronnie Novacek&#8217;s 1978 Corvette through the Greenbush Fourth of July Parade&#8211; a vehicle used in the Indianapolis 500 as a pace car. This entry earned &#8220;Best Car/Truck&#8221; in the parade. Altoz earned the &#8220;Best Float&#8221; award.</p></div>
<div id="attachment_268074" style="width: 1210px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-268074" loading="lazy" src="https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0718.jpg" alt="" width="1200" height="796" class="size-full wp-image-268074" srcset="https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0718.jpg 1200w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0718-300x199.jpg 300w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0718-1024x679.jpg 1024w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0718-768x509.jpg 768w" sizes="(max-width: 1200px) 100vw, 1200px" /><p id="caption-attachment-268074" class="wp-caption-text">photo by Ryan Bergeron<br />Merle Lorenson of Thief River Falls drives his 1937 AR John Deere, pulling a tractor made of wood. This entry earned the &#8220;Best Tractor&#8221; in the Greenbush Fourth of July Parade.</p></div>
<div id="attachment_268075" style="width: 1210px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-268075" loading="lazy" src="https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0695.jpg" alt="" width="1200" height="796" class="size-full wp-image-268075" srcset="https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0695.jpg 1200w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0695-300x199.jpg 300w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0695-1024x679.jpg 1024w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0695-768x509.jpg 768w" sizes="(max-width: 1200px) 100vw, 1200px" /><p id="caption-attachment-268075" class="wp-caption-text">photo by Ryan Bergeron<br />The Gator Elementary Wrestling cheerleaders and wrestlers earned the &#8220;Mayor&#8217;s Choice&#8221; award in this year&#8217;s Greenbush Fourth of July Parade.</p></div>
<div id="attachment_268076" style="width: 1210px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-268076" loading="lazy" src="https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0661.jpg" alt="" width="1200" height="796" class="size-full wp-image-268076" srcset="https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0661.jpg 1200w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0661-300x199.jpg 300w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0661-1024x679.jpg 1024w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0661-768x509.jpg 768w" sizes="(max-width: 1200px) 100vw, 1200px" /><p id="caption-attachment-268076" class="wp-caption-text">photo by Ryan Bergeron<br />Altoz won the &#8220;Best Float&#8221; award in the 2022 Greenbush Fourth of July Parade.</p></div>
<div id="attachment_268077" style="width: 1210px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-268077" loading="lazy" src="https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0655.jpg" alt="" width="1200" height="796" class="size-full wp-image-268077" srcset="https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0655.jpg 1200w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0655-300x199.jpg 300w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0655-1024x679.jpg 1024w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0655-768x509.jpg 768w" sizes="(max-width: 1200px) 100vw, 1200px" /><p id="caption-attachment-268077" class="wp-caption-text">photo by Ryan Bergeron<br />Hanson&#8217;s Trophies and Engraving earned the &#8220;Most Patriotic&#8221; award in the Greenbush Fourth of July Parade.</p></div>
<div id="attachment_268078" style="width: 1210px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-268078" loading="lazy" src="https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0581.jpg" alt="" width="1200" height="796" class="size-full wp-image-268078" srcset="https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0581.jpg 1200w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0581-300x199.jpg 300w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0581-1024x679.jpg 1024w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0581-768x509.jpg 768w" sizes="(max-width: 1200px) 100vw, 1200px" /><p id="caption-attachment-268078" class="wp-caption-text">photo by Ryan Bergeron<br />Husband and wife Henry &#8220;Buster&#8221; and Geraldine Nubson make their way through the Greenbush Fourth of July Parade as this year&#8217;s Grand Marshals. The couple has made their home in Greenbush for the last 55 years and Buster was born in Greenbush in 1935, living here for most of his life.</p></div>
<div id="attachment_268079" style="width: 1210px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-268079" loading="lazy" src="https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0565.jpg" alt="" width="1200" height="796" class="size-full wp-image-268079" srcset="https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0565.jpg 1200w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0565-300x199.jpg 300w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0565-1024x679.jpg 1024w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0565-768x509.jpg 768w" sizes="(max-width: 1200px) 100vw, 1200px" /><p id="caption-attachment-268079" class="wp-caption-text">photo by Ryan Bergeron<br />Donna Langaas, the new local American Legion Commander, presents the American flag during the singing of the National Anthem to kick of the Greenbush Fourth of July Parade.</p></div>
<div id="attachment_268080" style="width: 1210px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-268080" loading="lazy" src="https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0557.jpg" alt="" width="1200" height="796" class="size-full wp-image-268080" srcset="https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0557.jpg 1200w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0557-300x199.jpg 300w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0557-1024x679.jpg 1024w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0557-768x509.jpg 768w" sizes="(max-width: 1200px) 100vw, 1200px" /><p id="caption-attachment-268080" class="wp-caption-text">photo by Ryan Bergeron<br />Jaxen Schneider, Jazlynn Stennes, and Michaela Knutson look down the street as the Greenbush Fourth of July Parade participants began their procession down Main Street. This year&#8217;s parade included 64 entries.</p></div>
<div id="attachment_268081" style="width: 1210px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-268081" loading="lazy" src="https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0545.jpg" alt="" width="1200" height="796" class="size-full wp-image-268081" srcset="https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0545.jpg 1200w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0545-300x199.jpg 300w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0545-1024x679.jpg 1024w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0545-768x509.jpg 768w" sizes="(max-width: 1200px) 100vw, 1200px" /><p id="caption-attachment-268081" class="wp-caption-text">photo by Ryan Bergeron<br />Alex Grossi plays his guitar during the &#8220;Quiet Riot&#8221; performance at the Greenbush Race Park on July 3.</p></div>
<div id="attachment_268082" style="width: 1210px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-268082" loading="lazy" src="https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0488.jpg" alt="" width="1200" height="796" class="size-full wp-image-268082" srcset="https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0488.jpg 1200w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0488-300x199.jpg 300w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0488-1024x679.jpg 1024w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0488-768x509.jpg 768w" sizes="(max-width: 1200px) 100vw, 1200px" /><p id="caption-attachment-268082" class="wp-caption-text">photo by Ryan Bergeron<br />Jizzy Pearl performs as the lead singer of the heavy metal band &#8220;Quiet Riot&#8221; at the Greenbush Race Park on July 3.</p></div>
<div id="attachment_268083" style="width: 1210px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-268083" loading="lazy" src="https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0460.jpg" alt="" width="1200" height="796" class="size-full wp-image-268083" srcset="https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0460.jpg 1200w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0460-300x199.jpg 300w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0460-1024x679.jpg 1024w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0460-768x509.jpg 768w" sizes="(max-width: 1200px) 100vw, 1200px" /><p id="caption-attachment-268083" class="wp-caption-text">photo by Ryan Bergeron<br />Simon Daniels, lead singer of the glam metal band &#8220;Autograph,&#8221; raises both his arms, as he performs at the Greenbush Race Park on July 3. The group opened that night for &#8220;Quiet Riot.&#8221;</p></div>
<div id="attachment_268084" style="width: 1210px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-268084" loading="lazy" src="https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0403.jpg" alt="" width="1200" height="796" class="size-full wp-image-268084" srcset="https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0403.jpg 1200w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0403-300x199.jpg 300w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0403-1024x679.jpg 1024w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0403-768x509.jpg 768w" sizes="(max-width: 1200px) 100vw, 1200px" /><p id="caption-attachment-268084" class="wp-caption-text">photo by Ryan Bergeron<br />Andy Hanson throws a bag during the Corn Hole Tournament along Main Street in Greenbush on July 2. Run by Northern Minnesota Cornhole, the tournament included 16 teams.</p></div>
<div id="attachment_268085" style="width: 1210px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-268085" loading="lazy" src="https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0395.jpg" alt="" width="1200" height="796" class="size-full wp-image-268085" srcset="https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0395.jpg 1200w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0395-300x199.jpg 300w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0395-1024x679.jpg 1024w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0395-768x509.jpg 768w" sizes="(max-width: 1200px) 100vw, 1200px" /><p id="caption-attachment-268085" class="wp-caption-text">photo by Ryan Bergeron<br />Samantha Venables and Auroura Bentow celebrate after finishing their run in the Greenbush 5K Color Walk/Run event on July 2.</p></div>
<div id="attachment_268086" style="width: 1210px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-268086" loading="lazy" src="https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0359.jpg" alt="" width="1200" height="796" class="size-full wp-image-268086" srcset="https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0359.jpg 1200w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0359-300x199.jpg 300w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0359-1024x679.jpg 1024w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0359-768x509.jpg 768w" sizes="(max-width: 1200px) 100vw, 1200px" /><p id="caption-attachment-268086" class="wp-caption-text">photo by Ryan Bergeron<br />Splattered in color, Dylan Heggedal completes his run at the Greenbush 5K Walk/Run on July 2. Heggedal finished third in the event, while Russ Sorenson finished first and Trace Bakke second.</p></div>
<div id="attachment_268087" style="width: 1210px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-268087" loading="lazy" src="https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0301.jpg" alt="" width="1200" height="796" class="size-full wp-image-268087" srcset="https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0301.jpg 1200w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0301-300x199.jpg 300w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0301-1024x679.jpg 1024w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0301-768x509.jpg 768w" sizes="(max-width: 1200px) 100vw, 1200px" /><p id="caption-attachment-268087" class="wp-caption-text">photo by Ryan Bergeron<br />Participants at the Greenbush 5K Color Walk/Run took a group photo at the starting line on July 2. A total of 94 people participated in the event.</p></div>
<div id="attachment_268088" style="width: 1210px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-268088" loading="lazy" src="https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0266.jpg" alt="" width="1200" height="796" class="size-full wp-image-268088" srcset="https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0266.jpg 1200w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0266-300x199.jpg 300w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0266-1024x679.jpg 1024w, https://www.page1publications.com/wp-content/uploads/2022/07/DSC_0266-768x509.jpg 768w" sizes="(max-width: 1200px) 100vw, 1200px" /><p id="caption-attachment-268088" class="wp-caption-text">photo by Ryan Bergeron<br />Kissing Company performs at the street dance along Main Street in Greenbush on July 1, an event sponsored by One Better Liquor.</p></div>
<p>Greenbush hosted Fourth of July festivities officially from June 30 to July 4. It provided various food and drink opportunities, a 5K Color Walk/Run, a Mak-It Personalized Plate/Bowl Activity, a Corn Hole Tournament, stock car and bush car racing, fireworks, motocross racing, and music. The music included a street dance led by the group &#8220;Kissing Company&#8221; along Main Street on July 1 and a concert delivered by the groups “Autograph&#8221; and &#8220;Quiet Riot&#8221; at the Greenbush Race Park on July 3.</p>
<p>The annual Greenbush Fourth of July Parade also took place, led by this year’s Grand Marshals— longtime Greenbush residents and husband and wife— Henry (Buster) and Gerry Nubson. Below is a list of this year’s parade winners.</p>
<p>Most Patriotic: Hanson Trophies and Engraving<br />
Best Car/Truck: Ronnie Novacek’s 1978 Corvette<br />
Best Tractor: Merle Lorenson&#8217;s 1937 AR John Deere<br />
Best Float: Altoz<br />
Mayor’s Choice: Gator Elementary Wrestling</p>
<div id="civsci-id-540505248" data-civicscience-widget="d5f56b13-7d08-5f44-f93c-473e2c63563d"></div>
<p><script type="text/javascript" async src="https://get.civicscience.com/jspoll/5/csw-polyfills.js"></script></p>
<div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.page1publications.com/2022/07/08/greenbush-fourth-of-july-celebration-provides-days-of-fun/" data-a2a-title="Greenbush Fourth of July Celebration provides days of fun"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.page1publications.com%2F2022%2F07%2F08%2Fgreenbush-fourth-of-july-celebration-provides-days-of-fun%2F&amp;linkname=Greenbush%20Fourth%20of%20July%20Celebration%20provides%20days%20of%20fun" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.page1publications.com%2F2022%2F07%2F08%2Fgreenbush-fourth-of-july-celebration-provides-days-of-fun%2F&amp;linkname=Greenbush%20Fourth%20of%20July%20Celebration%20provides%20days%20of%20fun" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div>                </div><!-- .fl-post-content -->

                
        <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags">Posted in <a href="https://www.page1publications.com/category/breaking-news/" rel="category tag">Breaking News</a>, <a href="https://www.page1publications.com/category/news/" rel="category tag">News</a></div></div>                <div class="fl-comments">

    
    
            <div id="respond">

            <h3 class="fl-comments-respond-title">Leave a Comment</h3>

            
                <form class="fl-comment-form" action="https://www.page1publications.com/wp-comments-post.php"
                      method="post">

                                                <label for="author">Name (required)</label>
                            <input type="text" name="author" class="form-control" value=""
                                   tabindex="1" aria-required='true' />
                            <br/>

                            <label for="email">Email (will not be published) (required)</label>
                            <input type="text" name="email" class="form-control"
                                   value=""
                                   tabindex="2" aria-required='true' />
                            <br/>
<!-- hide website url field
                            <label for="url">Website</label>
                            <input type="text" name="url" class="form-control"
                                   value="" tabindex="3"/>
                            <br/>
-->
                        
                    <label for="comment">Comment</label>
                    <textarea name="comment" class="form-control" cols="60" rows="8" tabindex="4"></textarea>
                    <br/>

                                        <div class="g-recaptcha" data-sitekey="6LdvRcMZAAAAAEXIplzSR6ZvSkSZTV1inA8BbwkV"></div>
                    <br>


                    <input name="submit" type="submit" class="btn btn-primary" tabindex="5"
                           value="Submit Comment"/>
                    <input type='hidden' name='comment_post_ID' value='268068' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
                    <input type="hidden" id="ct_checkjs_fc3cf452d3da8402bebb765225ce8c0e" name="ct_checkjs" value="0" />
                    <div class="fl-comment-form-cancel">
                        <a rel="nofollow" id="cancel-comment-reply-link" href="/2022/07/08/greenbush-fourth-of-july-celebration-provides-days-of-fun/#respond" style="display:none;">Click here to cancel reply.</a>                    </div>

                </form>
                    </div>
    
    
</div>

        
                <style>
                    .fl-post-featured-post {
                        border-bottom: 1px solid #e6e6e6;
                        margin-bottom: 10px;
                        padding-bottom: 0px;
                        margin-left: 20px;
                    }

                    .fl-post-featured-image-beside .fl-post-featured-image {
                        float: left;
                        width: 120px;
                        padding-right: 5px;
                    }

                    .fl-clear {
                        clear: both;
                    }

                    h5.fl-post-featured-title {
                        margin: 0 0 10px;
                        padding: 0;
                        font-weight: bold;
                    }

                    .fl-post-featured-image {
                        margin-bottom: 10px;
                    }

                    .fl-post-featured-image img {
                        height: auto !important;
                        width: 100% !important;
                    }

                    .fl-post-featured-header {
                        margin-bottom: 15px;
                    }

                </style>
                <div id="webads-related-posts">
                    <h3>Related Posts</h3>


                    
                        <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image"
                             itemscope="itemscope" itemtype="http://schema.org/BlogPosting">

                                                            <div class="fl-post-featured-image">
                                    <a href="https://www.page1publications.com/2022/07/04/achievement-rooted-in-family-tradition/" rel="bookmark"
                                       title="Achievement rooted in family tradition">
                                        <img width="300" height="300" src="https://www.page1publications.com/wp-content/uploads/2022/06/DSC_0017-1-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" />                                    </a>
                                </div>
                            
                            <div class="fl-post-featured-header">
                                <h5 class="fl-post-featured-title" itemprop="headline">
                                    <a href="https://www.page1publications.com/2022/07/04/achievement-rooted-in-family-tradition/" rel="bookmark"
                                       title="Achievement rooted in family tradition">Achievement rooted in family tradition</a>
                                </h5>
                                <div class="fl-post-featured-meta">
														<span class="fl-post-featured-date">
					July 4, 2022				</span>
                                                                            <span class="fl-sep"> | </span>
                                        <span class="fl-post-featured-comments">
					<a href="https://www.page1publications.com/2022/07/04/achievement-rooted-in-family-tradition/#respond" tabindex="-1" aria-hidden="true">No Comments »</a></span>
                                                                    </div>
                            </div>


                            <div class="fl-clear"></div>

                        </div>


                        
                        <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image"
                             itemscope="itemscope" itemtype="http://schema.org/BlogPosting">

                                                            <div class="fl-post-featured-image">
                                    <a href="https://www.page1publications.com/2022/06/30/finding-a-home-on-the-softball-diamond-former-gator-missy-bruggeman-named-to-minnesota-softball-hall-of-fame/" rel="bookmark"
                                       title="Finding a home on the softball diamond Former: Gator Missy Bruggeman named to Minnesota Softball Hall of Fame">
                                        <img width="300" height="300" src="https://www.page1publications.com/wp-content/uploads/2022/06/287763774_10102103456413682_5586908207182765458_n-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" />                                    </a>
                                </div>
                            
                            <div class="fl-post-featured-header">
                                <h5 class="fl-post-featured-title" itemprop="headline">
                                    <a href="https://www.page1publications.com/2022/06/30/finding-a-home-on-the-softball-diamond-former-gator-missy-bruggeman-named-to-minnesota-softball-hall-of-fame/" rel="bookmark"
                                       title="Finding a home on the softball diamond Former: Gator Missy Bruggeman named to Minnesota Softball Hall of Fame">Finding a home on the softball diamond Former: Gator Missy Bruggeman named to Minnesota Softball Hall of Fame</a>
                                </h5>
                                <div class="fl-post-featured-meta">
														<span class="fl-post-featured-date">
					June 30, 2022				</span>
                                                                            <span class="fl-sep"> | </span>
                                        <span class="fl-post-featured-comments">
					<a href="https://www.page1publications.com/2022/06/30/finding-a-home-on-the-softball-diamond-former-gator-missy-bruggeman-named-to-minnesota-softball-hall-of-fame/#respond" tabindex="-1" aria-hidden="true">No Comments »</a></span>
                                                                    </div>
                            </div>


                            <div class="fl-clear"></div>

                        </div>


                        
                        <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image"
                             itemscope="itemscope" itemtype="http://schema.org/BlogPosting">

                                                            <div class="fl-post-featured-image">
                                    <a href="https://www.page1publications.com/2022/06/23/three-gator-golfers-conclude-season-at-state/" rel="bookmark"
                                       title="Three Gator golfers conclude season at state">
                                        <img width="300" height="300" src="https://www.page1publications.com/wp-content/uploads/2022/06/Gator-Golfers-Compete-at-State-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" />                                    </a>
                                </div>
                            
                            <div class="fl-post-featured-header">
                                <h5 class="fl-post-featured-title" itemprop="headline">
                                    <a href="https://www.page1publications.com/2022/06/23/three-gator-golfers-conclude-season-at-state/" rel="bookmark"
                                       title="Three Gator golfers conclude season at state">Three Gator golfers conclude season at state</a>
                                </h5>
                                <div class="fl-post-featured-meta">
														<span class="fl-post-featured-date">
					June 23, 2022				</span>
                                                                            <span class="fl-sep"> | </span>
                                        <span class="fl-post-featured-comments">
					<a href="https://www.page1publications.com/2022/06/23/three-gator-golfers-conclude-season-at-state/#respond" tabindex="-1" aria-hidden="true">No Comments »</a></span>
                                                                    </div>
                            </div>


                            <div class="fl-clear"></div>

                        </div>


                        
                        <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image"
                             itemscope="itemscope" itemtype="http://schema.org/BlogPosting">

                                                            <div class="fl-post-featured-image">
                                    <a href="https://www.page1publications.com/2022/06/17/bgmr-freeze-athletes-battle-at-state-track-and-field-meet-skeim-captures-sixth-place-state-finish/" rel="bookmark"
                                       title="BGMR/Freeze athletes battle at state track and field meet: Skeim captures sixth place state finish">
                                        <img width="300" height="300" src="https://www.page1publications.com/wp-content/uploads/2022/06/DSC_0021-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" />                                    </a>
                                </div>
                            
                            <div class="fl-post-featured-header">
                                <h5 class="fl-post-featured-title" itemprop="headline">
                                    <a href="https://www.page1publications.com/2022/06/17/bgmr-freeze-athletes-battle-at-state-track-and-field-meet-skeim-captures-sixth-place-state-finish/" rel="bookmark"
                                       title="BGMR/Freeze athletes battle at state track and field meet: Skeim captures sixth place state finish">BGMR/Freeze athletes battle at state track and field meet: Skeim captures sixth place state finish</a>
                                </h5>
                                <div class="fl-post-featured-meta">
														<span class="fl-post-featured-date">
					June 17, 2022				</span>
                                                                            <span class="fl-sep"> | </span>
                                        <span class="fl-post-featured-comments">
					<a href="https://www.page1publications.com/2022/06/17/bgmr-freeze-athletes-battle-at-state-track-and-field-meet-skeim-captures-sixth-place-state-finish/#respond" tabindex="-1" aria-hidden="true">No Comments »</a></span>
                                                                    </div>
                            </div>


                            <div class="fl-clear"></div>

                        </div>


                        
                        <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image"
                             itemscope="itemscope" itemtype="http://schema.org/BlogPosting">

                                                            <div class="fl-post-featured-image">
                                    <a href="https://www.page1publications.com/2022/06/13/june-13-lake-of-the-woods-mn-fishing-report/" rel="bookmark"
                                       title="June 13 Lake of the Woods MN Fishing Report">
                                        <img width="240" height="300" src="https://www.page1publications.com/wp-content/uploads/2022/06/Father-son-walleye_Zippel-Bay-Resort_061222-240x300.jpeg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" />                                    </a>
                                </div>
                            
                            <div class="fl-post-featured-header">
                                <h5 class="fl-post-featured-title" itemprop="headline">
                                    <a href="https://www.page1publications.com/2022/06/13/june-13-lake-of-the-woods-mn-fishing-report/" rel="bookmark"
                                       title="June 13 Lake of the Woods MN Fishing Report">June 13 Lake of the Woods MN Fishing Report</a>
                                </h5>
                                <div class="fl-post-featured-meta">
														<span class="fl-post-featured-date">
					June 13, 2022				</span>
                                                                            <span class="fl-sep"> | </span>
                                        <span class="fl-post-featured-comments">
					<a href="https://www.page1publications.com/2022/06/13/june-13-lake-of-the-woods-mn-fishing-report/#respond" tabindex="-1" aria-hidden="true">No Comments »</a></span>
                                                                    </div>
                            </div>


                            <div class="fl-clear"></div>

                        </div>


                        
                </div>
                </article>
<!-- .fl-post -->		</div>

		<div class="fl-sidebar  fl-sidebar-right fl-sidebar-display-always col-md-3" itemscope="itemscope" itemtype="https://schema.org/WPSideBar">
		<aside id="adrotate_widgets-6" class="fl-widget widget_adrotate_widgets"><div class="a-single a-22"><a onClick="ga('send', 'event', 'Adverts', 'click', 'INewz', 1.00, {'nonInteraction': 1});" href="https://www.page1publications.com/inewz/"><img onload="ga('send', 'event', 'Adverts', 'impression', 'INewz', 2.00, {'nonInteraction': 1});" src="https://www.page1publications.com/wp-content/uploads/2019/10/inewzwebad.jpg" /></a></div></aside><aside id="webads_oev1_widget-2" class="fl-widget widget_webads_oev1_widget"><h4 class="fl-widget-title">Page 1 Publications Supplements</h4>
        <script>
            jQuery(document).ready(function() {
                loadOnlineEdition('931', '', '', '', '1811', '931');
            });
        </script>

        <div class="fl-photo fl-photo-align-center" itemscope="" itemtype="http://schema.org/ImageObject">
            <div class="fl-photo-content">
                <a id="webads-online-edition-931" href="https://www.google.com" target="_blank" /></a>
            </div>
        </div>

        </aside><aside id="webads_oev1_widget-3" class="fl-widget widget_webads_oev1_widget">
        <script>
            jQuery(document).ready(function() {
                loadOnlineEdition('931', '224402', '', '', '1811', '931');
            });
        </script>

        <div class="fl-photo fl-photo-align-center" itemscope="" itemtype="http://schema.org/ImageObject">
            <div class="fl-photo-content">
                <a id="webads-online-edition-931" href="https://www.google.com" target="_blank" /></a>
            </div>
        </div>

        </aside><aside id="webads_displayads_widget-2" class="fl-widget widget_webads_displayads_widget"><h4 class="fl-widget-title">Our Advertisers</h4>

                <style>
                    #displayAds img {
                        width: 100%;
                        height: auto;
                    }

                                        #displayAdsWrapper {
                        height: 1500px;
                        overflow: hidden;
                    }
                    

                </style>

                <div id="displayAdsWrapper">
                    <div id="displayAds">
                        <ul id="displayAdsUL">
                        </ul>
                    </div>
                </div>

                <script>
                    (function( $ ) {
                        $(document).ready(function () {
                            $("#displayAdsWrapper").hide();
                            loadDisplayAds(1811, 100, 1);
                        });

                        function loadDisplayAds(memberid, count, thumbtype) {

                            if (memberid !== undefined) {
                                var memberid = String(memberid);
                                var count = String(count);
                                var thumbtype = String(thumbtype);
                                if (memberid.length == 4) {
                                    $.ajax({
                                        url: "https://ws.iadsnetwork.com/displayads.svc/GetDisplayAds",
                                        data: { "memberid": memberid, "count": count, "thumbtype": thumbtype },
                                        dataType: "json",
                                        type: "GET",
                                        contentType: "application/json; charset=utf-8",
                                        success: function (data) {

                                            if (data.d != null) {
                                                $("#displayAdsUL").empty();
                                                var dtDisplayAd = data.d;

                                                for (i = 0; i < dtDisplayAd.length; i++) {
                                                    if (typeof ga !== "undefined") {
                                                        // safe to use the function
                                                        ga('send','event','Adverts','impression',dtDisplayAd[i].name,2,{'nonInteraction':1});
                                                        $("#displayAdsUL").append('<li style="padding-bottom: 5px;"><a onClick="ga(\'send\',\'event\',\'Adverts\',\'click\',\'' + dtDisplayAd[i].name + '\',1,{\'nonInteraction\':1});" href="' + dtDisplayAd[i].url + '" target="_blank"><img src="' + dtDisplayAd[i].img + '" alt=" " /></a></li>');
                                                    } else {
                                                        $("#displayAdsUL").append('<li style="padding-bottom: 5px;"><a href="' + dtDisplayAd[i].url + '" target="_blank"><img src="' + dtDisplayAd[i].img + '" alt=" " /></a></li>');
                                                    }
                                                }
                                                setTimeout(function(){ startSlider(i) }, 1000);
                                            }
                                        },
                                        error: function (d) {
                                            //alert("Error");
                                        }
                                    });
                                } else {
                                    $("#displayAdsWrapper").empty();
                                }
                            }
                        }

                        function startSlider(count) {
                            var isAuto = true;
                            var pauseLen = '5000';

                            $("#displayAds").sudoSlider({
                                vertical: true,
                                continuous: true,
                                                                slideCount: count+1,
                                auto: isAuto,
                                                                autoHeight: false,
                                                                pause:  pauseLen,
                                prevNext: false,
                                useCSS: false,
                                autoWidth: true
                            });
                            $("#displayAdsWrapper").show();
                        }
                    })( jQuery );

                </script>

                </aside><aside id="adrotate_widgets-5" class="fl-widget widget_adrotate_widgets"><!-- Error, Ad (14) is not available at this time due to schedule/budgeting/geolocation/mobile restrictions! --></aside><aside id="adrotate_widgets-2" class="fl-widget widget_adrotate_widgets"><div class="g g-1"><div class="g-dyn a-3 c-1"><a onClick="ga('send', 'event', 'Adverts', 'click', 'Employment', 1.00, {'nonInteraction': 1});" href="http://www.hometownemploymentnetwork.com/default.aspx?affiliateid=1119" target="_blank"><img onload="ga('send', 'event', 'Adverts', 'impression', 'Employment', 2.00, {'nonInteraction': 1});" src="https://www.page1publications.com/wp-content/uploads/2016/08/Jobs.png" /></a></div></div></aside><aside id="adrotate_widgets-3" class="fl-widget widget_adrotate_widgets"><div class="a-single a-10"><a onClick="ga('send', 'event', 'Adverts', 'click', 'Breaking News Signup', 1.00, {'nonInteraction': 1});" href="https://www.page1publications.com/breaking-news-signup/"><img onload="ga('send', 'event', 'Adverts', 'impression', 'Breaking News Signup', 2.00, {'nonInteraction': 1});" src="https://www.page1publications.com/wp-content/uploads/2016/04/breakingNewsHeader.png" /></a></div></aside><aside id="webads_facebook_widget-2" class="fl-widget widget_webads_facebook_widget"><h4 class="fl-widget-title">Like Us On Facebook</h4>
        <div id="fb-root"></div>
        <script async defer crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v5.0"></script>


        <div class="fb-page" data-href="https://www.facebook.com/Northern-Light-Region-123704497685047/" data-tabs="" data-width="" data-height="" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><blockquote cite="https://www.facebook.com/facebook" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/facebook">Facebook</a></blockquote></div>
        

        </aside><aside id="webads_facebook_widget-4" class="fl-widget widget_webads_facebook_widget">
        <div id="fb-root"></div>
        <script async defer crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v5.0"></script>


        <div class="fb-page" data-href="https://www.facebook.com/North-Star-News-344310152276116/" data-tabs="" data-width="" data-height="" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><blockquote cite="https://www.facebook.com/facebook" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/facebook">Facebook</a></blockquote></div>
        

        </aside><aside id="webads_facebook_widget-3" class="fl-widget widget_webads_facebook_widget">
        <div id="fb-root"></div>
        <script async defer crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v5.0"></script>


        <div class="fb-page" data-href="https://www.facebook.com/The-Exponent-East-Grand-Forks-MN-106126462791312/" data-tabs="" data-width="" data-height="" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><blockquote cite="https://www.facebook.com/facebook" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/facebook">Facebook</a></blockquote></div>
        

        </aside><aside id="webads_facebook_widget-5" class="fl-widget widget_webads_facebook_widget">
        <div id="fb-root"></div>
        <script async defer crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v5.0"></script>


        <div class="fb-page" data-href="https://www.facebook.com/thetribune.greenbush.mn/?rf=146220848755581" data-tabs="" data-width="" data-height="" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><blockquote cite="https://www.facebook.com/facebook" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/facebook">Facebook</a></blockquote></div>
        

        </aside><aside id="adrotate_widgets-4" class="fl-widget widget_adrotate_widgets"><div class="a-single a-4"><script type="text/javascript" data-params="jsads">
m3ads_system = "MNA";
m3ads_partnernumber = 237166;
m3ads_numberadverts = 1;
m3ads_imagewidth = 300;
m3ads_imageheight = 250;
</script>
<script type="text/javascript" src="//cdn.feed.mna.org/resources/scripts/jsAds-1.4.min.js"></script></div></aside>	</div>

	</div>
</div>

			
	</div><!-- .fl-page-content -->
				</div><!-- .fl-page -->
		<footer class="fl-page-footer-wrap" itemscope="itemscope" itemtype="http://schema.org/WPFooter">
		<div class="fl-page-footer-widgets">
	<div class="fl-page-footer-widgets-container container">
		<div class="fl-page-footer-widgets-row row">
		<div class="col-sm-4 col-md-4 fl-page-footer-widget-col fl-page-footer-widget-col-1"><aside id="nav_menu-3" class="fl-widget widget_nav_menu"><h4 class="fl-widget-title">Page 1 Publications</h4><div class="menu-footer-menu-1-container"><ul id="menu-footer-menu-1" class="menu"><li id="menu-item-228" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-228"><a href="https://www.page1publications.com/">Home</a></li>
<li id="menu-item-22319" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22319"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=1b39bd64-3bf8-4219-b2d6-c49010cd5792">North Star News</a></li>
<li id="menu-item-22320" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22320"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=0edf69db-7621-496a-bc5d-30c51d25f9ef">Northern Light Region</a></li>
<li id="menu-item-22321" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22321"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=7e6a7f3b-d60a-4328-9883-3a86f55219b7">The Exponent</a></li>
<li id="menu-item-22322" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22322"><a target="_blank" rel="noopener noreferrer" href="http://1811.newstogo.us/editionviewer/default.aspx?Publication=bfda4ff1-9fd3-4b96-bfad-af5c10439939">The Tribune</a></li>
<li id="menu-item-264337" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-264337"><a target="_blank" rel="noopener noreferrer" href="https://www.newstogo.us/editionviewer/default.aspx?Publication=0e4896ee-3a4d-423f-97fb-dc025cfed655">Supplements</a></li>
<li id="menu-item-265748" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-265748"><a target="_blank" rel="noopener noreferrer" href="https://www.newstogo.us/editionviewer/default.aspx?Publication=47737b56-6ab7-4a1b-9649-d73a2ea73970">Lake of the Woods Connection</a></li>
<li id="menu-item-21800" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21800"><a href="https://www.page1publications.com/about-us/">About Us</a></li>
</ul></div></aside></div><div class="col-sm-4 col-md-4 fl-page-footer-widget-col fl-page-footer-widget-col-2"><aside id="webads_syndicated_stories_menu_widget-2" class="fl-widget widget_webads_syndicated_stories_menu_widget"><h4 class="fl-widget-title">US &#038; World News</h4> 
   
   <div><ul class="menu">
   <li class="menu-item menu-item-type-taxonomy"><a href="https://www.page1publications.com/syndicated_category/united-states/">US</a></li>
   <li class="menu-item menu-item-type-taxonomy"><a href="https://www.page1publications.com/syndicated_category/sports/">Sports</a></li>
   <li class="menu-item menu-item-type-taxonomy"><a href="https://www.page1publications.com/syndicated_category/entertainment/">Entertainment</a></li>
   <li class="menu-item menu-item-type-taxonomy"><a href="https://www.page1publications.com/syndicated_category/technology/">Technology</a></li>
   <li class="menu-item menu-item-type-taxonomy"><a href="https://www.page1publications.com/syndicated_category/political/">Politics</a></li>
   <li class="menu-item menu-item-type-taxonomy"><a href="https://www.page1publications.com/syndicated_category/world/">World</a></li>
   <li class="menu-item menu-item-type-taxonomy"><a href="https://www.page1publications.com/syndicated_category/business/">Business</a></li>
   <li class="menu-item menu-item-type-taxonomy"><a href="https://www.page1publications.com/syndicated_category/health/">Health</a></li>
   </ul></div>   
   
   </aside></div><div class="col-sm-4 col-md-4 fl-page-footer-widget-col fl-page-footer-widget-col-3"><aside id="nav_menu-5" class="fl-widget widget_nav_menu"><h4 class="fl-widget-title">Odds &#038; Ends</h4><div class="menu-footer-menu-3-container"><ul id="menu-footer-menu-3" class="menu"><li id="menu-item-216" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-216"><a href="https://www.page1publications.com/crossword/">Crossword Puzzle</a></li>
<li id="menu-item-217" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-217"><a href="https://www.page1publications.com/event-calendar/">Event Calendar</a></li>
<li id="menu-item-1473" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1473"><a href="https://www.page1publications.com/poll/">Online Poll</a></li>
</ul></div></aside></div>		</div>
	</div>
</div><!-- .fl-page-footer-widgets -->
<div class="fl-page-footer">
	<div class="fl-page-footer-container container">
		<div class="fl-page-footer-row row">
			<div class="col-md-12 text-center clearfix"><div class="fl-page-footer-text fl-page-footer-text-1">This website is powered by <a href="http://www.websitesfornewspapers.com" target="_blank"><i><strong>WebsitesForNewspapers.com</strong></i></a></div></div>					</div>
	</div>
</div><!-- .fl-page-footer -->
	</footer>
	
<script type="text/javascript" >				
				window.addEventListener('DOMContentLoaded', function () {
					setTimeout(function(){
						if( document.querySelectorAll('[name^=ct_checkjs]').length > 0 ) {
			                apbct_public_sendAJAX(
			                    { action: 'apbct_js_keys__get' },
			                    { callback: apbct_js_keys__set_input_value, apbct_ajax: 1 }
			                );
			            }
					},0);					    
				});				
			</script><link rel='stylesheet' id='font-awesome-5-css'  href='https://www.page1publications.com/wp-content/plugins/bb-plugin/fonts/fontawesome/5.15.1/css/all.min.css?ver=2.4.2.2' media='all' />
<script src='https://www.page1publications.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.dyngroup.js' id='adrotate-dyngroup-js'></script>
<script src='https://www.google.com/recaptcha/api.js?ver=5.5.9' id='recaptcha-scripts-js'></script>
<script id='wp-polls-js-extra'>
var pollsL10n = {"ajax_url":"https:\/\/www.page1publications.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
</script>
<script src='https://www.page1publications.com/wp-content/plugins/webads-polls/polls-js.js?ver=2.72' id='wp-polls-js'></script>
<script src='https://www.page1publications.com/wp-content/plugins/ecwd-frontend-event-management/js/autocomplete.js?ver=1.0.13' id='sc_form-autocomplete-js'></script>
<script src='https://www.page1publications.com/wp-content/plugins/bb-plugin/js/jquery.ba-throttle-debounce.min.js?ver=2.4.2.2' id='jquery-throttle-js'></script>
<script src='https://www.page1publications.com/wp-content/plugins/bb-plugin/js/jquery.magnificpopup.min.js?ver=2.4.2.2' id='jquery-magnificpopup-js'></script>
<script src='https://www.page1publications.com/wp-content/plugins/bb-plugin/js/jquery.fitvids.min.js?ver=1.2' id='jquery-fitvids-js'></script>
<script src='https://www.page1publications.com/wp-includes/js/comment-reply.min.js?ver=5.5.9' id='comment-reply-js'></script>
<script src='https://www.page1publications.com/wp-content/themes/bb-theme/js/bootstrap.min.js?ver=1.7.9' id='bootstrap-js'></script>
<script id='fl-automator-js-extra'>
var themeopts = {"medium_breakpoint":"992","mobile_breakpoint":"768"};
</script>
<script src='https://www.page1publications.com/wp-content/themes/bb-theme/js/theme.min.js?ver=1.7.9' id='fl-automator-js'></script>
<script src='https://www.page1publications.com/wp-includes/js/wp-embed.min.js?ver=5.5.9' id='wp-embed-js'></script>
<!-- AdRotate JS -->
<script type="text/javascript">
jQuery(document).ready(function(){if(jQuery.fn.gslider) {
	jQuery('.g-1').gslider({groupid:1,speed:6000,repeat_impressions:'Y'});
	jQuery('.g-3').gslider({groupid:3,speed:6000,repeat_impressions:'Y'});
}});
</script>
<!-- /AdRotate JS -->

</body>
</html>